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Introduction

HELLO STUDENTS

Welcome to the digital logic lab! In this lab, you will have the opportunity to experiment with and learn about
digital logic circuits. You will use a variety of equipment, such as power supplies, digital multimeters, function
generators, and oscilloscopes as well as software tools for simulating and modeling digital circuits.

The focus of this lab is to provide hands-on experience for students studying digital electronics and computer
engineering, allowing you to apply the theoretical concepts you have learned in class to real-world situations. You
will learn how to design, build, and test digital circuits using a variety of logic gates and other digital building
blocks.

Throughout the lab, you will work on a series of exercises and projects designed to help you understand the
fundamental principles of digital logic. These exercises will include basic logic gates, such as AND, OR, and NOT, as
well as more complex circuits like flip-flops and counters.

This lab will require a lot of time, effort, and attention to details, so be prepared by reviewing the materials before
coming to class. You will be working with equipment that can be fragile and expensive, so please handle it with
care.

You will also be required to keep a lab notebook (paper or electronic), where you will record your observations and
measurements, and to present the results of your work. Also, you will be required to turn in lab reports each week.
Let's get started and have a great time learning about digital logic!



Introduction to PSPICE and Logic Gate Simulation

OJECTIVES

After completing this experiment, you will be able to
e Simulated the 7 fundamental logic gates on OrCAD PSPICE.

MATERIALS NEEDED

e OrCAD PSPICE
THEORY

ORCAD PSPICE:

In this experiment, we will simulate all 7 fundamental logic gates to gain familiarity with OrCAD PSPICE.

OrCAD PSpice is a software tool for simulating and analyzing the behavior of electronic circuits. It is a component
of the OrCAD electronic design automation (EDA) suite, which is used to design and manufacture electronic
systems and components.

PSpice provides a wide range of simulation models and analysis tools for analog, digital, and mixed-signal circuits.
It allows designers to analyze the performance of their circuits under different operating conditions and identify
potential issues before physically building and testing the circuits. The software has a graphical user interface (GUI)
that allows users to build and edit circuits using schematic capture and layout tools. It also includes a variety of
libraries of pre-defined components, such as transistors, resistors, capacitors, and integrated circuits, that can be
added to circuits.

PSpice is widely used in the electronics industry and academia for designing and testing electronic circuits,
including power supplies, amplifiers, filters, and controllers.

7 FUNDAMENTAL LOGIC GATES:

Digital logic gates are electronic circuits that perform logical operations on one or more input signals and produce
an output signal based on the logical operation. They are the basic building blocks of digital circuits and are used to
implement Boolean functions, which are mathematical functions that take in one or more input values and
produce a single output value.

There are several types of digital logic gates, including:
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PRELIMINARY PROCEDURE

Read the lab.

1.

Draw the output waveform for each logic gate. We will use these results to compare with your PSPICE

simulations.

2.

NOT

AND

OR

XOR

NAND

NOR

XNOR

Table 1.8



PROCEDURE

SIMULATING A NOT GATE IN PSPICE

STARTING A NEW PROJECT
1. Press File > New > Project to begin a new project.

File | Design Edit View Tools Place PCB

New » Project...

Open » Design

Close Ctrl+F4 Library
VHDL File
Verilog File

Text File

Figure 1. 8

2. Inthe New Project window, title your file “FirstName-LastName-Lab1”, for example. Save it in a folder called
“Lab 1”. Check the box called Enable PSpice Simulation.

New Project

Name Michael-Granberry-Lab1

Location 4 haelgranbermyiiD esk]

Enable PSpice Simulation

Cancel

Figure 1.9

3. Inthe Create PSpice Project pop-up window, select Create a blank project and Press OK.

Create PSpice Project

Create based upon an existing project

Create a blank projec

Figure 1. 10

ADDING LIBRARIES
4. Press Place > Part or press P to bring up the parts library.



Place | PCE 5l Analysis Pipice A4

[} Part...

Figure 1. 11

In Place Part window, click the Add Library icon, . Inthe folder, open the library called 74LS, SOURCSTM.

Place Part

Part

Search for Part

Figure 1. 12

ADDING COMPONENTS TO SCHEMATIC

6.

Now that your libraries are imported, select 74LS in the library window and search for 74LS04 by typing it in
the search window and press ENTER/RETURN on your keyboard.

10



Part

74504

U?A
o2
74504

Figure 1. 13

7. Drag your mouse over your schematic window and place the NOT gate on your schematic.

Figure 1. 14

8. Inthe SOURCSTM library, search for DigStim1 and add one to your schematic. Double click “Implementation”
text and type “X” in the Value textbox with Display Format set to Name and Value. Press OK.
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Displa

DETMA Name: Imnle _ Font
ETrr=—o e i fault)
Value: -
vale Change...
Uta Digplay Format
T4L504

alue Exists
Value Exists

Default

Figure 1. 15

9. Add ports by going to Place > Hierarchical Port....

Place = PCE 5| Analysis PSpice  Acq
[t part..

PSpice Component...

Search Providers...

Database Part
T Wire
Auto Wire
Bus

Junction

Bus Entry

Met Alias...
MetGroup...

Power...

Ground...

Off-Page Connector...
Hierarchical Block...

Hierarchical Port...

Figure 1. 16

10. Search for PORTLEFT-R in the CAPSYM library. Press OK. Place at the input of the NOT gate.



Place Hierarchical Port >

et

FORTLEFT-L

Cancel

PORTBOTHAL
FORTEOTH-A | Add Library..
PORTLEFT-L

FORTLEFT-H H__JPORTLEFTL

FORTHO-L

———r—— -

R emowve Librany

Help
Libraries;

C 1

Dezign Cache Mame:

FORTLEFT-L

HetGroup Paort
[] Shows UrMNamed MetGroup

Figure 1. 17

11. Double click on the “PORTLEFT-R” text and rename it “X”.

Display Properties

DSTHI Font
BIr>—o Mame: Mame -

Adial 7 (default)
Implementstion = X

Value: [

Change...
i Display Fomat

B crricHT-M ] Color
u n [ = Do Mot Display

e
Walue Only i

Mame and Value Rotation

Walue if Value Exists
Text Justification

Default

Figure 1. 18

12. Similar for the output, place a PORTLEFT-L at the output of the NOT gate and rename it “out”.
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CEThA Faont

Mame: I )

Adial 7 (default)

Implementstion = X Value: I:ll.lﬂ _
Change...
Uia Display Format
x[=
T4L504

Value if Value Exists

Text Justification

Default

Figure 1. 19

13. To connect the components together on the schematic with wires, go to Place > Wire or press W.

5l Analysis  PSpice  Ac

U4 Part... P i
PSpice Component... r
| 1
1 Wire W
Lrkn Wire 3
Figure 1. 20

14. Connect the components together in a similar manner as shown below.

DSTMA

Implemeantation = X

T4L504

Figure 1. 21

CREATING A NEW SIMULATION PROFILE

15. Create a new simulation profile by pressing PSpice > New Simulation Profile or click the icon.
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Pipice | Accessories Oplions

[~|  Mew Simulation Profile

Figure 1. 22

16. In the pop-up window type “labl-sim”. Press Create when done. Leave Inherit From as none.

Mew Simulation

Mame:

Inhert From:

y(ulyl=

ot Schematic: SCHEMATIC

Figure 1. 23

17. A window called “Simulation Settings — lab1-sim” will pop-up. Set Run To Time to “1us”. This will make the
simulation run for 1us.

Simulation Settings - lab1-sim

Lo Analysis Type: Run To Time : seconds (TSTOP)
et Time Domain (Transient) - .

. Start saving data after : seconds

) Options:

Configuration Files Transient options:

General Settings ~
Options Maximum Step Sze seconds
Monte Carlo/Worst Case

Data Collection Parametric Sweep Skip initial transient bias point calculation (SKIPBP)
Probe Window Temperature (Sweep)

Save Bias Point R
Load Bias Point

Save Check Point

Output File Options...

Restart Simulation

Figure 1. 24

18. Next, click on Options > Gate Level Simulation > General and set DIGINITSTATE to O under the Value column.
Then press Apply, then OK.

15



Simulation Settings - lab1-sim

General Analog Simulation Name Value Default Value

Analysis General DIGMNTYMX Typical Typical
NOPREMSG

DIGINITSTATE 0 ML
MOSFET Option

Options DIGIOLVL 1 s 1
Analog Advanced

Configuration Files Auto Converge

Data Collection General

Probe Window Bias Point
Transient
Gate Level Simulation
General
Advanced
Output File

Initialize all flip-flops to:
General

Figure 1. 25

CREATING A SIMULATION STIMULI

OrCAD Capture Lite offers several ways to create simulation stimuli. One way is to do it manually and another way
is to treat the inputs as if they are clocks. We will look at both methods this lab.

CREATE MANUALLY
19. Click the DSTM1 symbol to select the part so that a purple dotted rectangle encloses the part.

Implemantation = X

Figure 1. 26

20. Right click on the DSTM1 symbol and click Edit PSpice Stimulus.

Show Footprint

Associate PSpice Model

Edit PSpice Stimulus

Figure 1. 27

21. A New Stimulus window will pop up with “X” already in the Name text field. In the Digital section, select Signal,

16



then press OK.

Mew Stimulus

Mame: [

Analog
E=P [exponential]

PULSE

~
™ PWL [piecewize linear)

" SFFM [single-frequency Fi)
" SIM [sinusoidal)

Drigital
" Clock
* Signal

CoBus widk [

Iritial Yalue: |0 |

Ok | Cancel |

Figure 1. 28

|
22. To add a new point or a transition to a stimulus, click the #===== icon. Now, the arrow cursor symbol has
become a pencil symbol. Use this tool to toggle your input signal between 0 and 1. That is, once you have this
tool selected, click on the green signal to change the logic level. Toggle your signal from 0 to 1 at 0.5us. Your
final signals should look like the following.

File Edit Stimulus Plot View Tools Window Help cadence

1Ed] SRS 8 =) &2 2| 7 | [0

Figure 1. 29

23. Press Save and press Yes to update schematic.

QUESTIOMN(ORSTMED-1040):

Update schematic?

Figure 1. 30

RUN SIMULATION

17



24. Place Voltage Level markers schematic by going to PSPICE > Markers > Voltage Level or press i icon.

Pspice | Accessories Options Window  Help

23 [~ MNew Simulation Profile i&l a = @ DE
L

Edit Simulation Profile

() Run

View Simulation Results

View Qutput File

Create Metlist

View Netlist

Advanced Analysis

Markers b %, Voltage Level

Bias Points b #1, Voltage Differential

Current Into Pin

Figure 1. 31

25. The Voltage Level markers must be placed on the wires.

DETMA

Implementation = X

N L e

Figure 1. 32

26. Press PSpice > Run or the E icon to run simulation.
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Pipice | Accessories Options  Window

23 |~ Mew Simulation Profile

Edit Simulation Profile

C} Run

Figure 1. 33

27. Running the simulation will cause the Allegro PSpice Simulator program to open which will contain a
simulation of your schematic. It should look like the screenshot below.

a x
cadence?

Figure 1. 34
28. Press Trace > Cursor > Display or press D to enable the cursor.

Trace | Plot  Tools Window Help

— Add Trace... Insert

Delete All Traces Ctrl+Delete

Performance Analysis...

Cursar k |_| Display

Figure 1. 35

29. This will let you see the level of your signal. Once enabled, left click and on your simulation to see the levels of
your signal. You can click hold and drag as well.
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Figure 1. 36

30. Compare your simulated results with your pre-lab.

SIMULATING AN AND GATE IN PSPICE
The implementation and simulation for an AND gate is very similar to the NOT gate demonstrated previously.

STARTING A NEW PROJECT

1. Create a new project by going to File > New > New Project....
2. Inthe New Project window, name your project and save it in a new folder.
3. Inthe Create PSPICE Project window, click Create a black project, then press OK.

ADDING LIBRARIES
4. The necessary libraries should already be added to your library list from implementing the NOT gate. If not,
refer to step 2 in the from the previous section.

ADDING COMPONENTS TO SCHEMATIC

5. Open your parts window by pressing P and search for 74LS08 in the 74LS library. The 74LS08 is an AND gate.
Place the AND gate on your schematic. So far you should have the following:

-

T4L508

v
<Re{Code>

Figure 1. 37

6. Place two DigStim1 parts on your schematic (one for each input). Double click on the “Implementation” text
and set the value to X and Y for each DigStim1.

7. Go to Place > Hierarchical Port... and place two PORTRIGHT-R ports to the left of the inputs of the AND gate.

20



Double click on the “PORTRIGHT-R” text and rename each port X and Y for each port.

Similarly, go to Place > Hierarchical Port... and place one PORTRIGHT-L port to the right of the output of the
AND gate. Double click on the “PORTLEFT-L” text and rename it out.

Press W for the wire tool and connect each component together with wires. So far you should have the
following:

DT
Implementation = X 1A
« : oilrt
L
Y
.
LETWe TALSDE

Implementation =

Figure 1. 38

CREATING A NEW SIMULATION PROFILE

10.

11.

12.

13.

v
Create a new simulation profile by pressing PSpice > New Simulation Profile or click the . icon.
In the pop-up window type “lab1-sim”. Press Create when done. Leave Inherit From as none.

A window called “Simulation Settings — lab1-sim” will pop-up. Set Run To Time to “1us”. This will make the
simulation run for 1us.

Next, click on Options > Gate Level Simulation > General and set DIGINITSTATE to 0 under the Value column.

Then press Apply, then OK.

CREATING A SIMULATION STIMULI
Now we will look at the second way to create simulation stimuli by treating the inputs as if they are clocks.

TREAT SIGNALS AS CLOCKS

14.

Click the DSTM1 symbol to select the part so that a purple dotted rectangle encloses the part.

Figure 1. 39

15. Right click on the DSTM1 symbol and click Edit PSpice Stimulus from the menu.

21



Show Footprint

Associate PSpice Model

Edit PSpice Stimulus

Figure 1. 40

16. A New Stimulus window will pop up with “X” already in the Name text field. In the Digital section, select Signal,
then press OK.

Mew Stimulus >

Marne: |><

Analag
(" E#P [exponential]

" PULSE

" PWL [piecewise linsar)

" SFFM [single-frequency Fi]
" SIN [sinuzoidal]

Drigital

* Clock

" Signal

" Bus width
[mitial W alue; | J

Ok, | Cancel |

Figure 1. 41

17. In the Clock Attributes window, set Specify by to Period and on time. Set Period (sec) to 160ns and On time
(sec) to 80ns. Press Apply, then OK.

22



Clock Attributes

Mame:
Specify by:

" Frequency and duty cocle
{* Period and on time

Perniod [zec) |'| EOnz

On time [zec] |8Dns{

[ritial walue | 0 - |

Time delay [zec) |D

Ok Cancel | A pply |

Figure 1. 42

18. Set another stimulus for Y, press Stimulus > New....

: Plot View Tools Windo

Mew... Alt+MN ]

Get... IMS
Figure 1. 43

mriinm



Mew Stimulus *

M arme: |"|’

Analog
" ExP [exponential)

" PULSE

" PWL [piecewise linear)

" SFFM [zingle-frequency FM)
" SIM [sinusoidal]

Drigital

{* Clack

" Signal

" Bus ‘Wwidth;
Iitial * alue: | J

ak | Cahicel |

Figure 1. 44

19. In the Clock Attributes window, set Specify by to Period and on time. Set Period (sec) to 80ns and On time
(sec) to 40ns. Press Apply, then OK.

Clock Attributes 4

Marne:
Specify by

(" Frequency and duty cycle
{* Period and on time

Period (sec] [80ns

O time [sec) |4Elns|

[nitial walue |E| - |

Time delay [zec) ||:|

ak. Cancel | Apply |

Figure 1. 45



20. Your Stimulus Editor should look like the following:

B Stimulus Editor - [LABT-AND.stI "]

- =]
B) File Edit Stimulus Plot View Tools Window Help

x

cadence - ¢ =
[ = = e T T

Figure 1. 46

21. Press Save and press Yes to update schematic.

QUESTIOM{ORSTMED-1040):

Update schemnatic?

Figure 1. 47

RUN SIMULATION

]

F i
22. Place Voltage Level markers schematic by going to PSPICE > Markers > Voltage Level or press the & icon.
The Voltage Level markers must be placed on the wires. Your schematic should look like the following:

CiSTh

Implementation = X 1A

x[_=
2 ot
a >—T——h
DETMZ
Bl T4LE0E
Implemsntation = \

Figure 1. 48

23. Press PSpice > Run or the E icon to run simulation. Running the simulation will cause the Allegro PSpice

Simulator program to open which will contain a simulation of your schematic. It should look similar to the
screenshot below:

25



L x
cadence®|

Figure 1. 49

24. Press Trace > Cursor > Display or press E to enable the cursor. This will let you see the level of your signal.
Once enabled, left click and on your simulation to see the levels of your signal. You can click hold and drag as
well.

8 x
cadence®
»

Figure 1. 50

25. Compare your simulated results with your pre-lab.

PRACTICE PSPICE

Here you will practice the steps above and simulate the remaining gates on your own.
Parts List in the 74LS library:

OR: 741532

74LS32

Figure 1. 51

XOR: 74LS86A
U2A

)

74LS86A

Figure 1. 52

NAND:
U13A

74LS00

Figure 1. 53
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NOR:
U2A

i

74LS02

Figure 1. 54

XNOR:

When you simulate the 74LS266, a ‘1’ will be simulated as a ‘2’ (high impedance).
U1A

j> s

7415266

Figure 1. 55

For the remaining logic gates, compare your simulated results with your pre-lab.

27



Circuit Introduction with LEDs

OJECTIVES

After completing this experiment, you will be able to:
e Use a DC power supply and DMM.
e Identify basic circuit components.
e Analyze a circuit containing a switch.
e Analyze a simple LED circuit and measure the forward voltage.

MATERIALS NEEDED

e One 330Q
e Red, orange, yellow, green, blue, white LEDs
e 7404 hex inverter IC

THEORY

DIGITAL MULTIMETER (DMM)

A DMM, or Digital Multimeter, is a versatile electronic device used to measure various electrical quantities in a
simple and convenient way. A DMM typically has a digital display that shows numerical readings for measurements
such as voltage, current, resistance, and sometimes frequency.

GROUND

In a circuit, "ground" refers to a common reference point or voltage level against which other voltages are
measured. It serves as a point of reference for electrical potential and is typically designated as the zero-voltage
point. The circuit symbol for ground is shown in Figure 2.1.

Figure 2.1

DC VOLTAGE SOURCE

A DC voltage source is a device that provides the appropriate DC voltage required by the device to function. 5
voltages (5V or +5.0V) are commonly used in digital systems. Two DC voltage source schematic symbols are shown

in Figure 2.2.
e
+5.0V — +%._0V
Figure 2. 2

RESISTOR

A resistor is an electronic component that limits the flow of electric current in a circuit. A resistor schematic
symbol is shown in Figure 2.3. The number next to the symbol tells the reader that the resistance is 330 ohms
(330Q) or 1000 ohms (1kQ). Sometimes the unit symbol ‘Q’ is left out on schematics.

330 1k
—W— AW

Figure 2.3
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SWITCH
A switch, as shown in Figure 2.3, is a simple circuit component used to control the flow of electricity.

_—_

Figure 2.4

It is typically used to manually open or close a circuit, allowing or preventing the current from flowing through the
circuit as shown in Figure 2.4.

A B A B
o o o 0
+ +
SV=— S5V—"
_—|— 330 _—|— 330
OC oC

T T

Figure 2. 5: Switch Open and Switch Closed

Figure 2.4 shows another way to draw the circuits in Figure 2.5. This method is preferred in digital logic and will be
used throughout this lab manual. Typically, the positive voltages are towards the top of the schematic and ground
is at the bottom.

+5.0V +5.0V
T T

+5.0V
| T
% 330 % 330 % 330

Figure 2. 6: Switch Open and Switch Closed

OHM’S LAW

When a voltage is applied across a resistor, the current flowing through the resistor can be calculated using to
Ohm's Law:

V=IRsI v
= f—1% = —
R
Ohm's Law states that the current () flowing through a resistor is directly proportional to the voltage (V) applied

across it and inversely proportional to the resistance (R) of the resistor.

EXAMPLE 1.1
Find the current flowing through and the voltage across the 330Q resister when the switch is closed and open.

SOLUTION
Since the DC voltage is V = 5V and the resistor has a resistance of R = 330Q), therefore by Ohm’s Law:

1=V isi5ma
TR 3300 M

V = IR = (15.15mA)(330Q) = 5V

29



Thus, the current flowing through the circuit is 15.15 milliampere or 15.15mA. The voltage across the resistor is
equal to the DC voltage source. When the switch is open, I = 04, and therefore the voltage across the resistor is:

V =1IR - 0V = 0A(3300)
When the switch is Open, node A has a voltage of 5V, and both nodes B and C have voltages of 0V. However, when
the switch is closed, both A and B are 5V and C remains at OV. The voltage across the Resistors is the difference

between the voltage at Node B and at Node C.

VB(; = VB - Vc 9 5VB - OVC = 5V5c.

Switch State | Node A, Va Node B, Vg Node C, V¢ Node B to C, Vg
Open 5V ov ov ov
Closed 5V 5V ov 5V

LED

A diode is an electronic component that allows electric current to flow in one direction while blocking it in the
opposite direction. It acts as a “one-way valve” for electrical current. The diode’s terminals are called the anode (+)
and cathode (-). An LED (Light-Emitting Diode) is a specific type of diode that emits light when current passes
through it. It is designed to convert electrical energy into light energy. The LED schematic symbol is show in Figure

2.6.
' o~

Figure 2. 7: LED

When the voltage across a diode is applied in the forward direction (anode connected to the positive terminal and
cathode connected to the negative terminal), it allows current to flow easily, similar to a closed switch. This is
known as the forward bias.

LED Forward Voltage, V;
Red 1.8v-2.2v
Orange 2.0V-2.2V
Yellow 2.0v-2.2v
Green 2.0v-3.5V
Blue 2.5v-3.7V
White 2.5V-3.7V

Table 2. 1: LED Forward Voltages

On the other hand, when the voltage is applied in the reverse direction (anode connected to the negative terminal
and cathode connected to the positive terminal), the diode blocks the current flow, acting as an open switch. This
is known as the reverse bias.

—'\/\/\,——|-0Anode ) ———AA\———OCathode (-)
330

. 330 %
5\/_—_.— N

Cathode (-) Anode (+)

i

Figure 2. 8: Circuit with LED and Resistor
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EXAMPLE 1.2
Find the current flowing through the circuit if the LED has a forward voltage is V¢ = 2V.

SOLUTION
Since V =5V, V¢= 2V, and R = 330Q, therefore by Ohm’s Law:
Vv _
j= 0D S SV g g
R 3300 3300
Thus, the current flowing through the circuit is 9.09 milliampere or 9.09mA. Also note that the voltage across the
resistor is 3V.

5V =2V +3V.

PRELIMINARY PROCEDURE

1. Readthelab.

2. Research resistors, switches, LEDs, breadboards, DC power supplies, and logic gates. Briefly paraphrase your
findings. This will help you understand the topics presented in this lab. In addition, when you write your lab
report, use your research as the theory section of your report. You may include images, graphs, equations, etc.

PROCEDURE

1. Measure the resistance of one 330Q and 1kQ resistor. Record the measured values in Table 2.2. It’s a good
habit to measure your resistors’ values before you place them into your circuit.

Resistor, Q Measured, Q
3300
1kQ

Table 2.2

2. Build Figure 2.9 on a breadboard. If switches are not available, then one can emulate a switch by using a wire.
Measure and record the voltages across each resistor when the switch is open and closed. Observe that Vag +
Vic = Vac = Vsupply When resistors are connected in series.

A oB +5.0V
A B
_ T K :
. 330 - YVy
5V— 330
T 1k 1k
LloC
-] loc L
— =
Figure 2.9
Switch State Measured, Vsuppiy Measured, Vas Measured, Vgc Measured, Vac
Open
Closed
Table 2.3

3. Modify your circuit by replacing the 1kQ resistor with an LED, as shown in Figure 2.10. Measure and record the
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voltage across the resistor as well as the LED’s forward voltage, Vs (anode to cathode). Observe that Vi. Vg =

VDC =5V.
+5.0V
AN OAnode (+) AN OAnode (+)
R 330 | 330
5V——
- T N
J-___ OCathode (-) ° Cathode (-)
Figure 2. 10
] . LED State
Switch State Forward Voltage, V¢ Voltage across Resistor, Vg
(On or off)
Open
Closed
Table 2.4

4. Open the switch and insert your LED in the other direction so that it’s reverse bias. When the switch is closed,
is the LED on or off? Notice that Vre, = Vsupply = 5V when the switch is closed.

+5.0V
AN OCathode (-) AAM OCathode (-)
s 330 ;Q 330 ;%
-] OAnode (+) _I_Anode (G
Figure 2. 11
Switch State Forward Voltage, V ey Voltage across Resistor, Vg (Ig:::itf?)
Open
Closed
Table 2.5

5. Close the switch and turn the LED around so that the LED turns on. Measure the forward voltage and voltage
across the resistor for each LED color.

LED

Forward Voltage, Vs

Voltage across Resistor, Vg

Red

Orange

Yellow

Green

Blue

White

Table 2.6

6. Connect two inverters in series (cascade) as shown in Figure 2.12. Check the logic when the input is connected
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to 5V, open (not connected to anything), and OV (Ground). Record your observations for these three cases in

Table 2.7.

LED LED

+5.0V

1
7404
1k

330 330

I A—wm—
— W\

Figure 2. 12
Wire State LED 1, (On or off) LED 2, (On or off)
5V
Open (Floating)
0V, Ground

Table 2.7

7. Connect the two inverters as cross-coupled inverters as shown in Figure 2.13. This is a basic latch circuit, the
most basic form of memory. This arrangement is not the best way to implement a latch but serves to illustrate
the concept (you will study latch circuits in more detail later). Check the logic when the input is connected to
5V, open (not connected to anything), OV (Ground), and back to open. Record your observations for these
three cases in Table 2.8.

+5.0V
| 7404
330
1k |
) ¥ LED
N
7404 =
Figure 2. 13
Wire State LED, (On or off)
5V
Open (Floating)
ov
Open (Floating)

Table 2.8
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EVALUATION AND REVIEW QUESTIONS

1. InFigure 2.9, we noticed that Vag+ Vec = Vac = Voc . Therefore, ohm’s law can be expanded to (Vas + Vac) = (Ras
+ Rac)(l). Find the current flowing through circuit. The same current flows through Ras and Rgc.

2. Find the current flowing through circuit then the voltage across each resistor.

2'4'%%
10k

WV
50

§ 2.2k

Figure 2. 14

3. According to your measurements in step 5, which LED has the least and most amount of current flowing

through it?

4. Find the current flowing through and the voltages across each resistor in Figure 2.15.

+5.0V

EE 1k
1

7404 330
1k

L

Figure 2. 15
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Logic Gates and Pull-Up and Pull-Down Resistors

OJECTIVES

After completing this experiment, you will be able to
e  Experimentally verify the truth tables for the NAND and NOR, and inverter gates.
e Use the NAND and NOR gates to formulate other basic logic gates.

MATERIALS NEEDED

e 7400 quad 2-input NAND gate
e 7402 quad 2-input NOR gate
e 7404 NOT gate (inverter)

e DMM probes

THEORY

LOGIC GATES

Logic gates are the basic building blocks of digital electronic circuits. They are devices that perform a specific logic
operation on one or more input signals and produce a single output signal. The most basic logic gates are the NOT
gate, AND gate, OR gate, and XOR (exclusive OR) gate. These gates can be combined to create more complex
circuits that perform more advanced logic operations.

UNIVERSAL LOGIC GATES
There are three types of logic gates that are considered to be "universal" because they can be combined to create
any other logic gate or digital circuit. These universal gates are:
e NAND (NOT-AND) gate: This gate performs the opposite function of an AND gate, meaning it produces a
low output (0) if all of its inputs are high, and a high output (1) otherwise.
e NOR (NOT-0OR) gate: This gate performs the opposite function of an OR gate, meaning it produces a high
output (1) if all of its inputs are low, and a low output (0) otherwise.
e NOT gate (inverter): As the name suggests, it inverts the input signal, so that a high input (1) produces a
low output (0), and vice versa.
e Since NAND and NOR gates are universal gates, any logic circuit can be implemented using only NAND
gates, or only NOR gates.

TTL (TRANSISTOR-TRANSISTOR LOGIC)

TTL (Transistor-Transistor Logic) is a type of digital logic circuit that uses transistors to switch between the two
logic levels of 0 and 1.

5V

High=1

Indeterminate
Region

Low=0

Figure 3. 1: TTL Switching Voltages
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As shown in Figure 3.1, the logic HIGH or binary ‘1’ level is typically represented by a voltage between 2.4V-5V,
while the logic LOW or binary ‘0’ level is represented by a voltage between 0V-0.4V. The exact voltage levels may
vary depending on the specific type of TTL circuit.

HOW TO CREATE INPUT SIGNALS IN THE LAB

Pull-down and pull-up resistors are used in electronic circuits to establish a known or defined voltage level when a
switch is open. They are typically used in digital circuits to prevent floating or undefined states that could lead to
unreliable or incorrect readings.

+5.0V

+5.0V 1k, Pull-Up
T

| — OVout OVout

% 1k, Pull-Down

Figure 3. 2

PULL-DOWN RESISTOR

A pull-down resistor is connected between the signal line and ground. When the switch is open, the pull-down
resistor ensures that the voltage is “pulled down” to a LOW level (e.g., 0 volts or ground). This establishes a clear
"off" or "0" state for the signal.

PULL-UP RESISTOR

On the other hand, a pull-up resistor is connected between the signal line and a positive voltage source (e.g., Vcc
or +5 volts). When the switch is open, the pull-up resistor “pulls” the voltage up to a high level (e.g., 5 volts). This
establishes a clear "on" or "1" state for the signal.

When the switch is closed, the pull-down or pull-up resistor has little effect as the switch takes precedence and
overrides the resistor's influence on the signal voltage level.

Vin
Switch State Pull-Down Pull-Up
Open ov, ‘0’ | 5V, ‘1’
Closed 5V, ‘1 ; ov, ‘0

Table3.1

In digital circuits, it's important to have a well-defined voltage level to ensure reliable signal interpretation by the
receiving circuitry (such as microcontrollers or logic gates).

NAMING PORTS ON A SCHEMATIC
To simplify the schematic, we can replace the entire pull-up or pull-down network with just the port.

+5.0V

AL__>— ADI/. Vin

Figure 3.3
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PRELIMINARY PROCEDURE

1. Readthelab.

2.  Number the pins on the gates of each circuit in the procedure.
3. Determine the Prelab X output (1 or 0) column corresponding to each figure in the procedure.

PROCEDURE

1. Build Figure 3.# on a breadboard and use either a switch or a wire to implement the switch. Measure the

voltage at node V,,: when the switch is open and closed.

i Pull-Down, Voltage, | Binary Value, Pull-Up, Binary Value,
Switch Stat
witch State Vin (1oro0) Voltage, Vin (1or0)
Open
Close
Table 3. 2

2. Build the following circuits and complete their corresponding table. Use a DMM to measure and record the
output voltage for each input combination, as well as determine its binary representation.

a. Figure 3.4 through 3.13 and Table 3.3 through 3.12, respectively.

=] r—

7400
Figure 3.4
Inputs Output
A B Prelab, X X Measured Output Voltage
0 0
0 1
1 0
1 1
Table3.3
A j—/
= 0
B
7402
Figure 3.5
Inputs Output
A B Prelab, X X Measured Output Voltage
0 0
0 1
1 0
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1

Table3.4

A D—/—aDc—G
7404

Figure 3. 6

Inputs

Prelab Output

Output

A

X

X

Measured Output
Voltage

1

0

Table3.5

AD—/E

Figure 3.7

Inputs

Prelab Output

Output

A

X

Measured Output
Voltage

1

0

Table 3.6

==

7402
Figure 3.8
Inputs Prelab Output Output Measured Output
Voltage
A X X
1
0
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Table3.7

N =D S=D

7402 7402
Figure 3.9
Inputs Prelab Output Output Measured Output
Voltage
A X X
1
0
Table 3.8
A>—— {j o
7402 >O_<:|x
B D—/{j Yo 7402
7402
Figure 3. 10
Inputs Output
A B Prelab, X X Measured Output Voltage
0 0
0 1
1 0
1 1
Table3.9
AC>—— —{ | p——<
—
T 7400 7400
Figure 3.11
Inputs Output
Prelab, X X Measured Output Voltage

Rr|lRr|O|O|>
R|O|lRr|(O|®




Table 3. 10

AC>— _'i::_jm:_\_. }_Gx
S Jl::j@_l_’ 7400

7400
Figure 3. 12
Inputs Output
A B Prelab, X X Measured Output Voltage
0 0
0 1
1 0
1 1
Table 3. 11
' <\
A —
—> _ ] T S
s[> = - —<x
T 7402 T 7400
7400
7400
Figure 3.13
Inputs Output
A B Prelab, X X Measured Output Voltage
0 0
0 1
1 0
1 1
Table 3. 12

EVALUATION AND REVIEW QUESTIONS

1. Look over the truth tables in your report.
a. Draw the circuits that are equivalent to the inverter.
b. Draw the circuit that is equivalent to the AND gate.

c. Draw the circuit that is equivalent to the OR gate.



2.

Assume you were troubleshooting a circuit containing a 4-input NAND gate and you discover that the output
of the NAND gate is always HIGH. Is this an indication of a bad gate? Explain your answer.
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Boolean Laws And DeMorgan’s Theorems

OJECTIVES

After completing this experiment, you will be able to
e Experimentally verify several of the rules for Boolean algebra.
e Design circuits to prove Rules 10 and 11.
e Experimentally determine the truth tables for circuits with three input variables, and use DeMorgan’s
theorem to prove algebraically whether they are equivalent.

MATERIALS NEEDED

e 7432 quad 2-input OR gate

e 7404 hex inverter

e 7408 quad 2-input AND gate
e  One 1kQ resister

e OnelED

e Two oscilloscope probes

e  One function generator probe

THEORY

BOOLEAN ALGEBRA

Boolean algebra is a mathematical system that is used to represent and manipulate logical expressions. It is based
on the two values of true and false (or 1 and 0), and includes operations such as AND, OR, and NOT. Boolean
algebra is used in computer science and electrical engineering to design and analyze digital circuits. It is also used
in mathematical logic and in the study of algorithms and complexity theory.

BASIC RULES OF BOOLEAN ALGEBRA
A+0=4
A+1=1
A-0=0

LNV EWNRE
e
+
b
Il
b

10. A+ AB=A
11. A+AB=A+B
12. (A+B)(A+C)=A+BC

PRELIMINARY PROCEDURE

1. Read the lab.
2.  Number the pins of each gate in all the circuits in the procedure.
3. Compete the Prelab Timing Diagrams for Table 3.1 through Table 3.6.
a. Figure 3.5 and 3.6 must be designed before completing the Prelab Timing Diagram.
4. Complete the Prelab X column for Table 3.9 and Table 3.10.
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PROCEDURE

FOR FIGURES 4.1 THROUGH 4.4:
1. Build the circuit on a breadboard.
2. Complete the experimental timing diagram.
3. Determine the Boolean rule.
4. Compare prelab and experimental timing diagrams.

FUNCTION GENERATOR SETTINGS:

1. 5V, square wave
2. 2.5V DC off set (This will make your square wave vary from OV to 5V rather than -2.5V to 2.5V)
3. 10k Hz frequency

o\
AlC_> > N
7} s <""output
0 4
Q-\D 7432
=0 =0
Figure 4.1
(

nout 4 | | | | | | | |
P | | | | | | | |
Prelab Timing L \ \ \ \ \ \ \ \
Diagram k (Low) } 1 1 l l l 1 1
\ \ \ \ \ \ \ \

Output

Experimental
Timing diagram L




A

A+0

Boolean Rule

Table 4.1

7432

= D<=
Output

Figure 4. 2

Prelab Timing

Diagram

Experimental Timing

diagram

Boolean Rule

Table 4.2
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Output

7408

ALC>

Figure 4. 3

> 5 —~— 5
+— +—
=} Q =} Qo
Q = a =
=} =}
£ o £ o
oo
£
S
00 =
£ [ o
C
= EE S
® 5 5 C o
?® e S
a 0O w T o

Table 4.3
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Output

D
7404 7408

ALC>

Figure 4.4

Prelab Timing

Diagram

Experimental Timing

diagram

Boolean Rule

Table 4.4
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FOR FIGURE 4.5 AND 4.6:

1. Draw and complete the circuit representation of rule 10 and 11.
2. Build the circuit on a breadboard.

3. Complete the experimental timing diagram.

4. Compare prelab and experimental timing diagrams.

RULE10: A+ AB=A4

ALC>

Square Wav e4

V1 =5V
V2 =0V

PW = 0.05ms j—/
PER = 0.1ms BL —-

0
Figure 4.5
ForB=0
|
[
A
< \ \ \ \ \ \ \ \
Input
\ \ \ \ \ \ \ \
Prelab Timing AB | \ \ \ \ \ \ \
Diagram L 1 1 1 1 1 1 1 1
\ \ \ \ \ \ \ \
\ \ \ \ \ \ \ \
Output \ \ \ \ \ \ \ \
\ \ \ \ \ \ \ \
| | | | | | | |
ForB=0
|
[
A
< \ \ \ \ \ \ \ \
Input
\ \ \ \ \ \ \ \
Experimental Timing AB | \ | | \ \ \ \
diagram L \ \ \ \ \ \ \ \
\ \ \ \ \ \ \ \
\ \ \ \ \ \ \ \
Output \ \ \ \ \ \ \ \
\ \ \ \ \ \ \ \
| | | | | | | |

Table 4.5



Prelab Timing

Diagram

Experimental Timing

diagram

Table 4.6
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A+B

RULE 11: A+ AB

@

0.05ms

0.1ms

5V
ov

AL>
Square Wav e4
V1
V2
PW
PER

Figure 4. 6

Prelab Timing

Diagram

Experimental Timing

diagram
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Prelab Timing

Diagram

Experimental Timing

diagram

Table 4.8
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MORE CIRCUITS

Build the following circuits and complete their corresponding table. Record the state of the LED, as well as
determine its binary representation. Figure 4.7 — 4.8 and Table 4.9 — 4.10, respectively.

A -
—)
X
" 7432
B[ > 7408
7404 1k
c[>
7404 ¥ e0

2
o
Figure 4.7

Inputs Prelab Output Output LED
A B C X X (On or Off)
0 0 0
0 0 1
0 1 0
0 1 1
1 0 0
1 0 1
1 1 0
1 1 1

Table 4.9



AD—/ —
7404

T 7408
B> 7432 1k
cL_>
!!i LED
Y
o
Figure 4. 8
Inputs Prelab Output Output LED
A B X X (On or Off)
0 0
0 0
0 1
0 1
1 0
1 0
1 1
1 1
Table 4. 10
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EVALUATION AND REVIEW QUESTIONS
1. Theequation X = A(A + B) + C is equivalentto X = A + C. Prove this with Boolean algebra.

2. Show how to implement the logic in Question 1 with NOR gates.

3. Draw two equivalent circuits that could prove Rule 12. Show the left side of the equation as one circuit and
the right side as another circuit.

4. Determine whether the circuits in Figures 4.7 and 4.8 perform equivalent logic. Then, using DeMorgan’s
theorem, prove your answer.

5. Write the Boolean expression for the circuit shown in Figure 4.9. Then, using DeMorgan’s theorem, prove that
the circuit is equivalent to that shown in Figure 4.1.

HIGH
o

7404
7408

7404

Figure 4.9
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Logic Circuit Simplification

OJECTIVES

After completing this experiment, you will be able to
e Develop the truth table for a BCD invalid code detector.
e Use a Karnaugh map to simplify the expression.
e Build and test a circuit that implements the simplified expression.
e Predicts the effect of “faults” in the circuit.

MATERIALS NEEDED

e 7400 NAND gate

e LED

e  One 330Q resister
e  One 3.3kQ resister

THEORY

KARNAUGH MAPS

Karnaugh maps are graphical representations of Boolean algebra expressions that are used to simplify logic
circuits. They provide a visual way to group together terms in a Boolean expression that have a similar logical
structure, making it easier to identify and simplify the expression. The map consists of a grid of squares, each
representing a single term in the Boolean expression, with the value of the term indicated by the color or shading
of the square. The squares are arranged in a specific pattern, such as a circle or a rectangle, to make it easy to
identify and group together adjacent terms that have similar logical structure.

BCD (BINARY-CODED DECIMAL)

BCD (Binary-Coded Decimal) is a way to represent decimal numbers using binary digits (bits). In BCD, each decimal
digit (0-9) is represented by a four-bit binary number, allowing for a total of 10 unique combinations of bits.

Decimal Binary-Coded Decimal
0 0000
0001
0010
0011
0100
0101
0110
0111
1000
1001

Table 5. 1: Decimal to BCD

OO | N[O |W|IN|F-

For example, the decimal number "42" would be represented in BCD as "0100 0010". One of the main advantages
of using BCD is that it allows for easy conversion between decimal and binary representations, which can simplify
the design of digital circuits.

PRELIMINARY PROCEDURE

1. Readthe lab.
2. BCDinvalid code detector:
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Determine the Prelab X output column in Table 5.2.
Use Figure 5.1 (K-map) to determine the Boolean equation and its simplified expression.
Use the simplified Boolean equation to draw the circuit in the box given in Figure 5.2.
d. Number the pins of each gate in your circuit design.
3. BCD number divisible by three:
a. Repeat steps a through e for Table 5.4, Figure 5.3, and Figure 5.4.

0T o

PROCEDURE

BCD INVALID CODE DETECTOR

1. Build the circuit designed in Figured 5.2 on a breadboard.
2. Complete the truth table in Table 5.2 to verify the output of your design. If the LED is on, X = 1.

Input Output
A B C D Prelab X Experimental X | LED (On or Off)
0 0 0 0
0 0 0 1
0 0 1 0
0 0 1 1
0 1 0 0
0 1 0 1
0 1 1 0
0 1 1 1
1 0 0 0
1 0 0 1
1 0 1 0
1 0 1 1
1 1 0 0
1 1 0 1
1 1 1 0
1 1 1 1

Table 5.2



DC 00 01 11 10

AB

00

01

11

10

Figure 5. 1: K-Map

Minimum sum-of-products reads from map:

X =

Factoring D from both terms gives:

X =

Draw the circuit with D factored out:

Figure 5. 2

330

»w

.||
o

LED
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Problem Problem Effect

Number

1 Input D is open.

) The ground to the AND
gate is open.
A replace the 330Q

3 resister with a 3.3kQ
resister.

4 Insert the LED
backwards.

5 Input A is shorted to
ground.

Table 5.3
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BCD NUMBER DIVISIBLE BY THREE

1. Build the circuit designed in Figured 5.4 on a breadboard.
2. Complete the truth table in Table 5.4 to verify the output of your design. If the LED is on, X = 1.
Input Output
A B C D Prelab X Experimental X | LED (On or Off)
0 0 0 0
0 0 0 1
0 0 1 0
0 0 1 1
0 1 0 0
0 1 0 1
0 1 1 0
0 1 1 1
1 0 0 0
1 0 0 1
1 0 1 0
1 0 1 1
1 1 0 0
1 1 0 1
1 1 1 0
1 1 1 1
Table 5. 4
DC 00 01 11 10
AB
00
01
11
10

Figure 5. 3: K-Map
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Minimum sum-of-products reads from map:

X =

Draw the circuit:

Figure 5.4

330

LED

V74

.||
o
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EVALUATION AND REVIEW QUESTIONS

1.

Assume that the circuit in Figure 5.2 was constructed but doesn't work correctly. The output is correct for all
inputs except DCBA - 1000 and 1001. Suggest at least two possible problems that could account for this and
explain how you would isolate the exact problem.

Draw the equivalent circuit in Figure 5.2 using only NOR gates.

The A input was used in the truth table for the BCD invalid code detector (Table 5.2) but was not connected in
the circuit in Figure 5.2. Explain why not.

The circuit shown in Figure 5.6 has an output labeled “X Bar” = X. Write the expression for X; then, using
DeMorgan’s theorem, find the expression for X.

+5,0V
T
|
% 330
LED
\,
2
DBar[_> &
ar
B [ , 7408
c [>—

7400

Figure 5.5
Convert the SOP form of the expression for the invalid code detector (Step 2) into POS form.

Draw a circuit, using NAND gates, that implements the invalid code detector from the expression you found in
Step 2.
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Half / Full Adder PSPICE Simulation

OJECTIVES

After completing this experiment, you will be able to
e Design and simulate a half adder.
e Design and simulate a fuller adder using two half adder modules.
e  Build a full adder using two half adders and experimentally verify its functionality.

MATERIALS NEEDED

e PSPICE

e One7432IC
e One7486IC
e One7408IC

THEORY

HALF ADDER

A half adder is a type of digital logic circuit that is used to perform the addition of two binary digits. It has two
inputs, called A and B, and two outputs, called sum and carry. The sum output is the XOR of the inputs, and the
carry output is the AND of the inputs.

The truth table for a half adder:

A B | Carry Sum
0 O 0 0
0 1 0 1
1 0 0 1
1 1 1 0

Table 6. 1: Half Adder Truth Table

Half adders are often used in combination with other circuits to perform addition of larger binary numbers. For
example, a full adder is a circuit that adds three binary digits and generates a carry output for addition of numbers
larger than 2 bits.

FULL ADDER

A full adder is a digital circuit that performs the addition of two binary digits (bits) and a carry-in bit. The output of
a full adder includes a sum bit and a carry-out bit. The sum bit is the result of the addition of the two input bits and
the carry-in bit, while the carry-out bit is generated when the sum of the three input bits results in a value greater

than 1 (in binary).

Full adders are commonly used in digital circuits to perform arithmetic operations, such as addition, subtraction,
and multiplication. They are often used in combination with other digital circuits, such as multiplexers and flip-
flops, to create more complex arithmetic logic units (ALUs) that can perform a wide range of arithmetic and logical

operations.

The truth table for a full adder:
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this truth table, A and B are the two input bits, Cin is the carry-in bit, Sum is the output sum bit, and Cout is the

output carry-out bit.

A B Cin| Cout Sum
0 0 O 0 0
0 0 1 0 1
0 1 O 0 1
0 1 1 1 0
1 0 O 0 1
1 0 1 1 0
1 1 0 1 0
1 1 1 1 1

Table 6. 2: Full Adder Truth Table
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PRELIMINARY PROCEDURE

From the truth tables above, trace the output waveform for the half adder and full adder.

-
+— . +—
IS > [t c £ S5
< > o @ < @ S > o
(2 (W) 5 (%) (W)
o0
[T

Figure 6. 2
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PROCEDURE

HALF ADDER IMPLEMENTATION

STARTING A NEW PROJECT

1. Create a new project by going to File > New > New Project....
2. Inthe New Project window, name your project and save it in a new folder.
3. Inthe Create PSPICE Project window, click Create a black project, then press OK.

ADDING LIBRARIES
4. Press Place > Part or press P to bring up the parts library.

Place | PCE 5l Analysis PSpice A4

[} Part...

Figure 6. 3

5. In Place Part window, click the Add Library icon, . Inthe folder, open the library called 74LS, SOURCSTM.

Figure 6.4

ADDING COMPONENTS TO SCHEMATIC
6. Inthe 7400 library, add the 7486 (XOR gate) and 7408 (AND gate) to the schematic.
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Figure 6. 5

7. Place two DigStim1 parts on your schematic (one for each input). Double click on the “Implementation” text
and set the value to X and Y for each DigStim1.

8. Go to Place > Hierarchical Port... and place two PORTRIGHT-R ports to the left of the inputs of the XOR gate.
Double click on the “PORTRIGHT-R” text and rename each port X and Y for each port.

9. Go to Place > Hierarchical Port... and place one PORTRIGHT-L port to the right of the output of the XOR gate.
Double click on the “PORTLEFT-L” text and rename it SUM.

10. Go to Place > Hierarchical Port... and place one PORTRIGHT-L port to the right of the output of the AND gate.
Double click on the “PORTLEFT-L” text and rename it OUT.

11. Press W for the wire tool and connect each component together with wires. So far you should have the
following:

DSTh1

Implementation = X
Lza
[ ]
2 D < JEum
[ 31-',4
DETMZ 7452
ERN T U1a
Implementation = L 1
5 ot
T40E
Figure 6. 6

CREATING A NEW SIMULATION PROFILE

s
12. Create a new simulation profile by pressing PSpice > New Simulation Profile or click the . icon.
13. In the pop-up window type “halfadder-sim”. Press Create when done. Leave Inherit From as none.

14. A window called “Simulation Settings — lab1-sim” will pop-up. Set Run To Time to “1us”. This will make the
simulation run for 1us.

15. Next, click on Options > Gate Level Simulation > General and set DIGINITSTATE to 0 under the Value column.
Then press Apply, then OK.

CREATING A SIMULATION STIMULI
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16. Click the DSTM1 symbol to select the part so that a purple dotted rectangle encloses the part.

Figure 6.7

17. Right click on the DSTM1 symbol and click Edit PSpice Stimulus from the menu.

Show Footprint

Associate PSpice Model

Edit PSpice Stimulus

Figure 6. 8

18. A New Stimulus window will pop up with “X” already in the Name text field. In the Digital section, select Signal,
then press OK.

Mew Stimulus *

Mame: |><

Analog
(" E¥P [exponential)

" PULSE

" PWL [piecewise linear)

(" SFFM [single-frequency Fi)
" SIM [sinuzoidal)

Digital

{+ Clock

" Signal

7 Bus  Width:
Imitial W alue: | J

0k | Canicel |

Figure 6.9

19. In the Clock Attributes window, set Specify by to Period and on time. Set Period (sec) to 500ns and On time
(sec) to 250ns. Press Apply, then OK.
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Clock Attributes
Marne: =
Specify by

" Frequency and duty cycle
{* Period and an lime

Period [sec] |500ns
On time [zec] |250ns

Iritial walue |0 -
Time delay [zec) |0

0K | Eancel| Apply

Figure 6. 10

20. Set another stimulus for Y, press Stimulus > New....

: Plat  View

Mew...

(3et...

Figure 6. 11

Tools

Alt+M
N5

REER |"|’

Analog
" EXP [exponential)

" PULSE

" PwL [piecewise linear)

" SFFM [single-frequency FM]
" SIM [sinusoidal)

Driggital
* Clock
" Signal

CoBus widh |
Imitial W alue: | J

QK. | Cancel ‘

Mew Stimulus *

Figure 6. 12

Windo
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21. Inthe Clock Attributes window, set Specify by to Period and on time. Set Period (sec) to 250ns and On time
(sec) to 125ns. Press Apply, then OK.

Clock Attributes >

Mame:

Specity by:
" Freguency and duty cycle
* Period and on time

Perind [zec] | 2500
On time [gec) W
Initial value IE
Time delay [zec) |0

Ok | Cancel ‘ Apply |

22. Your Stimulus Editor should look like the following:

23. Press Save and press Yes to update schematic.

RUN SIMULATION

#7
24. Place Voltage Level markers schematic by going to PSPICE > Markers > Voltage Level or press the o icon.
The Voltage Level markers must be placed on the wires. Your schematic should look like the following:

DSTH

Implementstion = X
oz
X D—ﬁ 3
2 ——————<__|5um
p i
CETME T4ER
s | U1A
Implementation = 1 4
2 < oo
T40E
Figure 6. 13

25. Press PSpice > Run or the m icon to run simulation. Running the simulation will cause the Allegro PSpice
Simulator program to open which will contain a simulation of your schematic. It should look similar to the
screenshot below:
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Figure 6. 14

26. Press Trace > Cursor > Display or press E to enable the cursor. This will let you see the level of your signal.
Once enabled, left click and on your simulation to see the levels of your signal. You can click hold and drag as
well.

| I N IO N I
1
SUH 8
COT 1

¥

Figure 6. 15

27. Compare your simulated results with your pre-lab.

FULL ADDER IMPLEMENTATION

1. Open the halfadder project created in the previous section.

STARTING A NEW PROJECT
2. Create a new project by going to File > New > New Project....

3. Inthe New Project window, name your project as fulladder and save it in a new folder.
4. Inthe Create PSPICE Project window, click Create a black project, then press OK.

5. Inthe project file directory, right click PAGE1 and rename it as halfadder.

SCHEMATICT : PAGE1]]

Analog or Mixed A/D

File Design Edit w Tools Place PCB Sl Analysis PSpice Access

LoBe. 0 H

fulladder.opj X Start Page X

File Hierarchy

Design Resources

= Mulladder.dsn

B[] SCHEMATIC1

gn Resources
ladder.d

&) A tate...
Design Cache o) fim

Library Edit Page
Rename

Schematic Page Properties

e

Edit selected object properties...

Edit Object Properties Lihrar,',-

Find

Layout

[ copy

Outputs

PSpice Resources

Lock

Logs

Delete

Before:

After:

Figure 6. 16 Figure 6. 17

ADDING LIBRARIES
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6. The necessary libraries should already be added to your library list from implementing the halfadder. If not,
refer to step 4 in the from the previous section.

COPYING HALF ADDER TO SCHEMATIC

7. Inthe halfadder project, open the half adder schematic. Then left click drag over the halfadder until the entire
circuit is selected. All components will be highlighted in purple:

Figure 6. 18
8. Go to Edit > Copy or press Ctrl+C to copy the halfadder circuit.

9. Paste the halfadder circuit on to the new schematic named halfadder.

FULL ADDER SCHEMATIC

10. In the project file directory, right click fulladder.dsn and click on New Schematic.... Leave the schematic name
as the default, SCHEMATIC2.

Analog or Mixed A/D

Mew Schematic

OK

Name:
= [E5) Mulladder.dsn -
= [ scHemarict | & Annotate..
E| halfadder MNew Schematic..,

Design Cache Design Properties...

SCHEMATICZ Cancel

Help

Library Save

Figure 6. 20

Save As..

Layout

Figure 6. 19

11. Right click the SCHEMATIC2 folder created in the project directory and click New Page. Rename the new page
as fulladder.

Mew Page in Schematic "SCHEMATIC2'

Mame: oK

fulladded Cancel

Help

Figure 6. 21
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12. Set SCHEMATIC2 as root folder. Right click SCHEMATIC2 and click Make Root. This will move SCHEMATIC2 to
the top.

Analog or Mixed A/D

= SCHEMATIC1

El halfadder
= SCHEMATIC2
El fulladder
Design Cache

Library

Before:

Figure 6. 22

Mew Page

Make Root

Rename

Properties

HEMATIC2

E| fulladder

SCHEM 1

E| halfadder
Design Cache
Library
Layout
Outputs
PSpice

Logs
After:

Figure 6. 23

13. Go to Place > Hierarchical Block.... In the Place Hierachical Block window, set Reference to halfadderla,
Implementation Type to Schematic View, and Implementation name to SCHEMATIC1. Then press OK.

ew Devices

HEM. 2 : fulladder]

Tools | Place | PCB Sl Ana PSpice

Fart...
PSpice Component..,
Search Providers...

Database Part

Wire

Auto Wire

Bus

* Jundion

. Bus Entry

. Met Alias...

MetGroup...

FPower...

Ground...

Off-Page Connector...

Hierarchical Block...

Figure 6. 24

Primitive
No
Yes

Default

Implementation

Implementation Type

Path and filename

Figure 6.

14. Left-click and drag to form a hierarchical box as shown below:

User Properties...

Help
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Figure 6. 25

15. Repeat step 12 and 13 to add another halfadder hierarchical block, however, name this one halfadder1b.

SCHEMATICY SCHEMATICT

Figure 6. 26

16. Add the 7432 OR gate (7400 library), DigStim1 (X, Y, Cin), PORTRIGHT-R (X, Y, Cin), PORTRIGHT-L (Sum, Cout),

and wires to the schematic. Wire your circuit together as shown below:

DSTM1

Implementation = X

halfadderia halfadderib
X X Sum X
ad Al Cout B— ad
CETM2
ETr—
Implementation = Y
SCHEMATICT SCHEMATICT
Cin T
DETM2
ET—
Implementation = Cin
Figure 6. 27

CREATING A NEW SIMULATION PROFILE

s
17. Create a new simulation profile by pressing PSpice > New Simulation Profile or click the . icon.
18. In the pop-up window type “fulladder-sim”. Press Create when done. Leave Inherit From as none.

19. A window called “Simulation Settings — lab1-sim” will pop-up. Set Run To Time to “1us”. This will make the
simulation run for 1us.

20. Next, click on Options > Gate Level Simulation > General and set DIGINITSTATE to 0 under the Value column.

Then press Apply, then OK.
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CREATING A SIMULATION STIMULI
21. Click the DSTM1 symbol to select the part so that a purple dotted rectangle encloses the part.

Lo e =

Figure 6. 28

22. Right click on the DSTM1 symbol and click Edit PSpice Stimulus from the menu.

Show Footprint

Associate Pspice Model

Edit Papice Stimulus

Figure 6. 29

23. A New Stimulus window will pop up with “X” already in the Name text field. In the Digital section, select Signal,
then press OK.

Mew Stimulus *

Mame: |><

Analog
" EXP [exponential)

" PULSE

" PwL [piecewize linear]

™ SFFM [single-frequency Fi)
" SIM [sinuzoidal)

Digital

{* Clack

" Signal

7 Bus ‘width: ’7
Initial Walue: | J

ok | Cancel |

Figure 6. 30

24. In the Clock Attributes window, set Specify by to Period and on time. Set Period (sec) to 1000ns and On time
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(sec) to 500ns. Press Apply, then OK.

Clock Attributes X
Mame: =
Specify by:

" Frequency and duty cycle
* Period and on time

Period [zec] ’W
O time [zec) ’W
Initial walue ’E
Tirne delay [sec) |0

Ok, | Cancel | Apply |

Figure 6. 31

25. Set another stimulus for Y, press Stimulus > New....

:F'Iu:ut View Toels Windo

Mew... Alt+MN
(3et,.. NS =

Figure 6. 32

26. Set Name to Y and Digital to Clock.

Mew Stimulus *

REER |"|’

Analog
" EXP [exponential)

" PULSE

" PwL [piecewise inear)

" SFFM [single-frequency FM]
" SIM [zinusaidal)

Dvigital

* Clock

" Signal

" Bus ‘width: Ii
Imitial W alue: | J

QK. | Cancel ‘

Figure 6. 33




27. Inthe Clock Attributes window, set Specify by to Period and on time. Set Period (sec) to 500ns and On time
(sec) to 250ns. Press Apply, then OK.

Clock Attributes >
Mame: ¥
Specify by

" Frequency and duty cycle
(% Period and on time

Period [sec) |500ns
On time [zec] W
Iritial value IE‘
Time delay [zec) |0

Cancel | Apply |

Figure 6. 34

28. Set another stimulus for Cin, press Stimulus > New....

:F'Iu:ut View Tools Windo

- _—
_ MNew... Alt+MN
|
— Get... INS =
Figure 6. 35
29. Set Name to Cin and Digital to Clock.
MNew Stimulus >
Mame: |Cin
Analag
" EXF [exponential]
" PULSE

" Pl [piecewize inear)

" SFFM [single-frequency FM)
" SIM [sinusoidal)

Digital

(* Clack

" Signal

" Bus  width:
Iitial ¥ alue:

ak | Cancel |

Figure 6. 36

30. In the Clock Attributes window, set Specify by to Period and on time. Set Period (sec) to 250ns and On time
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(sec) to 125ns. Press Apply, then OK.

Clock Attributes

Mame: Cin

Specify by:
" Frequency and duty cycle
* Period and on time

Period [sec) W

On time [sec) W
Initial value ’E

Time delay [zec] lﬂi

Ok | cancel |

Figure 6. 37

31. Your Stimulus Editor should look like the following:

Figure 6. 38

32. Press Save and press Yes to update schematic.

]

RUN SIMULATION
P
o icon.

33. Place Voltage Level markers schematic by going to PSPICE > Markers > Voltage Level or press the
The Voltage Level markers must be placed on the wires. Your schematic should look like the following:

CETMI
Implementation = X halfadderia halfaddert
X X Sum X
3 ¥ ¥ Cout — ¥
DETMZ
ET—
Implementation =

SCHEMATIC1

SCHEMATIC1

., onl >
DSTMS

Implementation = Cin

Figure 6. 39

34. Press PSpice > Run or the E icon to run simulation. Running the simulation will cause the Allegro PSpice
Simulator program to open which will contain a simulation of your schematic. It should look similar to the

screenshot below:
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Figure 6. 40

35. Press Trace > Cursor > Display or press E to enable the cursor. This will let you see the level of your signal.
Once enabled, left click and on your simulation to see the levels of your signal. You can click hold and drag as
well.

AL
SUH 1
couT 1

Figure 6. 41

36. Compare your simulated results with your pre-lab.

BREADBOARD

1. Draw the gate level schematic of the full adder designed in part A, build it on a breadboard, and verify its
functionality.

2. Record the output in Table 6.3 and compare your results with Table 6.2.

Input Output
B cin cout Sum

= O |O |k [k |O |O
o |k O [k O |+ |O

R (- (P |, |O |0 |0 O >

1 1

Table 6. 3: Full adder truth table
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2’s Complement Adder / Subtractor Circuit

OJECTIVES

After completing this experiment, you will be able to:
e Design, draw, construct, test, and demonstrate a 2s complement adder/subtractor system using only
7483 and 7486 ICs

MATERIALS NEEDED

e 7483 4-bit adder IC
e 7486 quad two-input XOR gate IC

e A4 LEDs
e 4330Q resisters
THEORY

ADDER / SUBTRACTOR CIRCUIT

A 4-bit adder/subtractor circuit can be constructed using a 7483 4-bit binary full adder and a 7486 XOR gate IC. The
7483 IC performs the addition, while the 7486 IC is used to handle the subtraction operation. The 7483 IC has two
inputs for each of the four bits (A0, A1, A2, A3) and (B0, B1, B2, B3), and the carry-in (Cin) and carry-out (Cout)
lines.

B: A B, A, By Ay By Ag

|

c c c c
FAI3IFAI2IFAHFA ¢

Figure 7.1

2’S COMPLEMENT

CONVERTING BETWEEN UNSIGNED AND SIGNED 2’S COMPLEMENT

In computing, the two's complement is a method used to represent signed integers. It allows both positive and
negative numbers to be stored and manipulated using the same binary arithmetic operations. In this
representation, the most significant bit (MSB) is used to represent the sign of the number, where 0 indicates a
positive number and 1 indicates a negative number.

To obtain the two's complement representation of a negative number, you follow these steps:

EXAMPLE 1: UNSIGNED TO 2’S COMPLEMENT
Let's find the two's complement representation of the decimal number -20 using 8-bit binary representation:

1. Write the digit as a positive unsigned binary number:

+20=00010100
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2. Starting from the right-hand side and moving to the left, copy all the bits including the first ‘1’ reached:

Giving us: 00010100 -> 100

3. Take the complement of the remaining bits:
Giving us: 00010 - 11101

Therefore, the two's complement representation of -20 in 8-bit binary is 11101100.

EXAMPLE 2: 2’S COMPLEMENT TO UNSIGNED

Now let’s convert back from the two's complement representation to the decimal representation:

4. Starting from the right-hand side and moving to the left, copy all the bits including the first ‘1’ reached:
Giving us: 11101100 - 100

1. Take the complement of the remaining bits:

Giving us: 11101 -> 00010

2. Finally, interpret the result as a positive binary number:

+20 = 00010100

In this way, the two's complement representation allows us to perform arithmetic operations on signed integers
using the standard binary arithmetic operations.

ADDITION AND SUBTRACTION WITH 2’S COMPLEMENT

EXAMPLE 3: ADDITION
Let's add two numbers, 3 and -2, represented in 4-bit two's complement.
1. Represent the numbers in 4-bit binary form:

3 =0011 (4-bit binary)
-2 = 2's complement of 2 (which is 0010) = 1110 (4-bit binary)

2. Add the binary numbers as if they were unsigned binary:

0011 (3)
+ 1110 (-2)

10001 (Carry-out)

3. Discard any overflow and keep the lower 4 bits of the result:

0001 (discard the carry-out)
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4. Interpret the result as a signed decimal number:
0001 (4-bit binary) = 1 (decimal)

Therefore, the result of adding 3 and -2 using two's complement representation is 1.

EXAMPLE 4: SUBTRACTION
Let's subtract two numbers, 5 and 3, represented in 4-bit two's complement.

1. Represent the numbers in 4-bit binary form:

5 =0101 (4-bit binary)
3 =0011 (4-bit binary)

2. Find the two's complement of the number to be subtracted (3):
-3 (decimal) = -2's complement of 3 (which is 0011) = 1101 (4-bit binary)
3. Add the binary numbers as if they were unsigned binary:

0101 (5)
+ 1101 (-3)

10010 (Carry-out)
4. Discard any overflow and keep the lower 4 bits of the result:
0010 (discard the carry-out)
Step 5: Interpret the result as a signed decimal number:
0010 (4-bit binary) = 2 (decimal)
Therefore, the result of subtracting 3 from 5 using two's complement representation is 2.
In summary, two's complement allows us to perform addition and subtraction of signed integers using the same

binary arithmetic operations as for unsigned integers. It simplifies the calculations and representation of negative
numbers in computer systems.

PRELIMINARY PROCEDURE

1. Readthelab.

2. Design the 2s complement adder/subtractor system shown in Figure 7.2. Use a 7486 IC for the four XOR gates.
Use a single 7483 adder IC for the four full adders (FAs).

3.  Number the pins on your design using the datasheets.

PROCEDURE
1. Circuit design:
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Figure 7. 2
2. Find the sum of the following 4-bit 2’s compliment numbers:
Inputs Outputs
A+ B =Ssum Sum LEDs, sum
4+3=7 0100 + 0011 0111 OFF4 ON3 ON; ON;
1+-1=-2 1111 + 1110
1+-2=-2 0001 + 1101
5+4=1 0101 + 1100
Table7.1

3. Find the difference of the following 4-bit 2’s complement numbers. The ‘+’ is not a typo:

Inputs Outputs
A — B = Dpiff Difference LEDs, piff
7-3=4 0111 + 1101 0100 OFF4 ON3 OFF, OFF;
-8-3=-5 [1000 + 0011
3--3=6 0011 + 0011
-4-2=-6 1100 + 1110
Table 7. 2

EVALUATION AND REVIEW QUESTIONS

1. Draw an 8-bit 2’s Complement Adder/Subtractor circuit using two 7483 4-bit adder ICs and eight 7486
quad two-input XOR gate ICs. Build can test your circuit if you have the parts and time during lab.
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Multiplexers

OJECTIVES

After completing this experiment, you will be able to:
e Use a multiplexer to construct a unsigned comparator, signed comparator, and a parity generator and
verify it’s functionality.
e Use and N-input multiplexer to implement a truth table containing 2N inputs.
e Troubleshoot a simulated failure in a test circuit.

MATERIALS NEEDED

74151A data selector/multiplexer
7404 hex inverter

One 330Q resister

One LED

THEORY

MULTIPLEXERS

A multiplexer, often abbreviated as "mux," is a fundamental digital logic circuit used in electronics and digital
communications to select one of several input signals and forward it to a single output. In other words, a
multiplexer is a device that allows multiple digital signals to share a common communication channel.

The basic theory behind a multiplexer is that it uses control inputs to select one of several inputs to route to the
output. The number of inputs that a multiplexer can handle is determined by the number of control inputs that it
has. For example, a 2-to-1 multiplexer has two inputs and one control input, while a 4-to-1 multiplexer has four
inputs and two control inputs.

The operation of a multiplexer can be visualized as a set of switches that are controlled by the control inputs.
Depending on the state of the control inputs, the corresponding switch is closed, allowing the signal from the
corresponding input to pass through to the output.

Multiplexers are used in a wide range of digital systems, including computer memory systems, data
communication systems, and digital signal processing circuits. They are often used in conjunction with other digital
logic circuits, such as decoders and demultiplexers, to perform complex digital operations.

PRELIMINARY PROCEDURE

1. Read the lab.

2. Complete the truth table for each circuit.

3. Complete the circuit diagram corresponding to each truth table.

4. Number the pins on each circuit using the 7404 and 74151A datasheet.
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PROCEDURE

2-BIT UNSIGNED COMPARATOR, A = B

1. Build Figure 8.1 on a breadboard and verify your results with Table 8.1.

Input Output
Connect Data to:

Al A0 B1 BO 4

0 0 0 0 1

B,

0 0 0 1 0

0 0 1 0

0 0 1 1

0 1 0 0

0 1 0 1

0 1 1 0

0 1 1 1

1 0 0 0

1 0 0 1

1 0 1 0

1 0 1 1

1 1 0 0

1 1 0 1

1 1 1 0

1 1 1 1

Table 8. 1: Truth table for 2-bit unsigned comparator, A > B
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Figure 8.1
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2-BIT SIGNED COMPARATOR, A > B

2. Build Figure 8.2 on a breadboard and verify your results with Table 8.2.

Input Output
Connect Data to:

Al A0 B1 BO 4

0 0 0 0

0 0 0 1

0 0 1 0

0 0 1 1

0 1 0 0

0 1 0 1

0 1 1 0

0 1 1 1

1 0 0 0

1 0 0 1

1 0 1 0 (=2=-2)-1

B,

1 0 1 1 (-2<-1)-0

1 1 0 0

1 1 0 1

1 1 1 0

1 1 1 1

Table 8. 2: Truth table for 2-bit signed comparator, A > B
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Figure 8. 2
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EVEN PARITY GENERATOR
3.

Build Figure 8.3 on a breadboard and verify your results with Table 8.3.

Input Output
Connect Data to:

A3 A2 Al A0 4

0 0 0 0 0

A

0 0 0 1 1

0 0 1 0

0 0 1 1

0 1 0 0

0 1 0 1

0 1 1 0

0 1 1 1

1 0 0 0

1 0 0 1

1 0 1 0

1 0 1 1

1 1 0 0

1 1 0 1

1 1 1 0

1 1 1 1

Table 8. 3: Truth table for even parity generator
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Figure 8.3
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EVALUATION AND REVIEW QUESTIONS

1.

Design a BCD invalid code detector using a 74151A. Show the connections for your design on Figure 8.4.

E

10
11 zHd
12
13
14
15
16
17

olm|

N

SO
S1
S2

74151A

Figure 8.4

Can you reverse the procedure of this experiment? That is, given the circuit, can you find the Boolean
expression? The circuit shown in Figure 8.5 uses 4:1 MUX. The inputs are called A2, A1, and AQO. The first term
is obtained by observing that when both select lines are LOW, A2 is routed to the output; therefore, the first
minterm is written A,A; A,. Using this as an example, find the remaining minterms.

ZA = A 4] Ay+

ul1s

—<_ ] zA

A2 |

. 74153
0

Figure 8.5
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Assume the circuit in Figure 8.1 had a short to ground on the output of the inverter. What effect would this
have on the output logic? What procedure would you use to find the problem?

Assume that the input to the 7404 in Figure 8.1 was open, making the output, B;, a constant LOW. Which lines
on the truth table would give incorrect readings on the output?

How can both an even and old parity be obtained from the circuit in Figure 8.3?
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Demultiplexer

OJECTIVES

After completing this experiment, you will be able to
e Complete the design of a multiple output combinational logic circuit using a demultiplexer.
e Use an oscilloscope to develop a timing diagram for a counter-decoder circuit.

MATERIALS NEEDED

e 7408 or 74LS08 quad AND gate

e 7474 dual D flip-flop

e  74L5139A decoder/demultiplexer

e LEDs: two red, two yellow, two green
e  Resisters: six 330Q, two 1.0kQ

e Two oscilloscope probes

e  One function generator probe

THEORY

DEMULTIPLEXER

A demultiplexer, also known as a " DMUX," is a digital circuit that takes in a single input and distributes it to
multiple outputs based on a control signal. The control signal specifies which output should receive the input data.

In a simple demultiplexer circuit, the input signal is connected to the decoder, which generates a binary code
based on the control signal. The binary code activates the corresponding switch, which directs the input signal to
the desired output. The other outputs are disabled, ensuring that the input signal is only received by the intended
output.

For most DMUXs, the selected output is LOW, whereas all others are HIGH. To implement a truth table that has a
single output variable with a decoder is not very efficient and is rarely done; however, a method for doing this is
shown conceptually in Figure 9.1. In this case, each line on the output represents one row on the truth table. If the
decoder has active-HIGH outputs, the output lines on the truth table with a 1 are ORed together, as illustrated in
Figure 9.1. The output of the OR gate represents the output function. If the outputs of the decoder are active-
LOW, the output lines with a 1 on the truth table are connected with a NAND gate. This is shown in Figure 9.2.

A DMUX is superior for implementing combinational logic when there are several outputs for the same set of input
variables. Each output line of the demultiplexer represents a line on the truth table. For active-HIGH decoder
outputs, OR gates are used, but a separate OR gate is required for each output function. Each OR gate output
represents a different output function. In the case of active-LOW decoder outputs, the OR gates are replaced by
NAND gates.
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Truth table for overflow error

Inputs Output
A B X X DMUX
0 0 0 0 Dy
0 0 1 S S | SR E Dy
0 1 0 0 D,
0 1 1 0 D,
1 0 0 0 Dy
1 0 1 0 Ds
1 1 0 | SR SN P Dy
1 1 | 0 D,
Select
——
C B A
(a) Truth table (b) Implementation

Figure 9. 1: Implementing a combinational logic function with an active HIGH DMUX.

Truth table for overflow error

Inputs Output

Ay By Z X

0 0 0 0

0 0 1 1 b ]
0 1 0 0

0 1 1 0

1 0 0 0

1 0 i 0

1 1 0 ) S | S
1 1 1 0

Select

——h——
C B A

TYTYYY

T

(a) Truth table

(b) Implementation

NAND gate drawn

as negative input

OR gate to emphasize
active-LOW inputs

Figure 9. 2: Implementing a combinational logic function with an active LOW DMUX.

PRELIMINARY PROCEDURE

Complete the design of a multiple output combinational logic circuit using the demultiplexer in Figure 9.4.
Number the pins on each circuit using the 74LS139A and 7474 datasheets.
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PROCEDURE

SYNOPSIS

A digital controller is required to control traffic at an intersection of a busy main street and an occasionally used
side street. The main street is to have a green light for as long as there is no vehicle on the side street. The side
street is to have a green light until there is no vehicle on the side street. There is a caution light (yellow) between
changes from green to red on both the main street and the side street. These requirements are illustrated in the
pictorial diagram in Figure 9.3.

Main

Side

Main

Side

Main

Side

000
900
@00
900
900
0@

Figure 9. 3: Requirements for the traffic light sequence.

Main

%]
o
@

900
000

We will focus on combinational logic in this experiment. The key elements can be separated into a Gray-code
counter and a traffic light logic block. The traffic light logic block has two inputs (2-bit Gray-code) and must have an
output for each of the four states. The 74LS139A is a dual 2-line to 4-line decoder and will do the job nicely, so it is

selected.

The traffic light logic block logic takes the four 2-bit Gray-codes and must produce six outputs for activating the
traffic lights. A truth table for the traffic light is given in Table 9.1. The truth table is organized in Gray-code, which
is used by sequential logic to step through the states. The output logic must be active-LOW (0) to drive LEDs that

simulate the traffic lights.

Light Outputs
State Code
Main Street Side Street

B A Red Yellow Green Red Yellow Green
0 0 1/OFF 1/OFF 0/ON 0/ON 1/OFF 1/OFF
0 1 1/OFF 0/ON 1/OFF 0/ON 1/OFF 1/OFF
1 1 0/ON 1/OFF 1/OFF 1/OFF 1/OFF 0/ON
1 0 0/ON 1/OFF 1/OFF 1/OFF 0/ON 1/0OFF

Table 9. 1: Truth table for the combinational logic. State outputs are active-LOW and light outputs are active-LOW.

TRAFFIC LIGHT COMBINATIONAL CIRCUIT

1. Build Figure 9.4 on a breadboard.
2. Complete Table 9.2 and compare your results with Table 9.1.
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R
+5.0V
330
Side green
N
Figure 9. 4: Traffic light output logic.
Light Outputs
State Code ] ]
Main Street Side Street
B A Red Yellow Green Red Yellow Green
0 0
0 1
1 1
1 0

Table 9. 2: Experimental truth table

GREY-CODE SEQUENCER

3. Although you have not studied counters yet, the Gray-code counter shown in Figure 9.5 is simple to build and
is the basis of the sequential logic in the traffic signal control logic. Construct the counter and connect the

94




counter outputs to the select inputs of the 74LS139A (switches should be removed). The select inputs are
labeled B and A on the 74LS139A.

to A to B

R2

+5.0V} 'v\k/\, s
1
J U1A j U1B
w w
14 14
o o

Q
;cu]m_ o4 pLTma D
- |
O O
Q7474 O 7474
Pulse Generator V1
5V 1Hz @
PP, n1
+5.0V—AW
1k
-0
Figure 9. 5: Gray-code counter for sequencing the traffic signal decoder.
RESULTS

4. Use an oscilloscope to develop a timing diagram for the counter-decoder traffic light circuit. Set the function
generator to 10Hz.

YO

Y1

Y2

Y3

Figure 9. 6: Timing Diagram

EVALUATION AND REVIEW QUESTIONS

1. Assume you needed an 8-bit decoder, but all that is available is a dual 74LS139A. Show how you could use it,
along with an inverter, to form an 8-bit decoder. (Hint: Consider using the enable inputs.)
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Why were the AND gates in Figure 9.2 drawn as negative-NOR gates?

What is the advantage of Gray-code for the state sequence?

For the circuit in Figure 9.4, what symptom would you obverse if:
a. The B select input were open?
b. The B select input were shorted to ground?
c. The enable (G) input were open?

How would the circuit be affected if instead of a Gray-code counter, you had a binary counter with the
sequence 00-01-10-117
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D Latch and D Flip-Flop

OJECTIVES

After completing this experiment, you will be able to
e Demonstrate how a latch can debounce a switch.
e Construct and test a gated D latch from four NAND gates and an inverter.
e Test a D flip-flop and investigate serval applications circuits for both the latch and the flip-flop.

MATERIALS NEEDED

e RedLED

e GreenLED

e 7486 quad XOR gate

e 7400 quad NAND gate

e 7404 hex inverter

e 7474 dual D flip-flop

e  Resisters: two 330Q, and two 1.0kQ

THEORY

D LATCH AND D FLIP-FLOP

As you have seen, combinational logic circuits are circuits in which the outputs are determined fully by the inputs.
Sequential logic circuits contain information about previous conditions. The difference is that sequential circuits
contain memory and combinational circuits do not.

The basic memory unit is the latch, which uses feedback to lock onto and hold data. It can be constructed from two
inverters, two NAND gates, or two NOR gates. The ability to remember previous conditions is easy to demonstrate
with Boolean algebra. For example, Figure 8.1 shows an S-R latch made from NAND gates. This circuit is widely
used for switch debouncing and is available as an integrated circuit containing four latches (the 74LS279A).

A simple modification of the basic latch is a circuit is called a gated D (for Data) latch. An enable input allows data
present on the D input to be transferred to the output when Enable is asserted. When the enable input is not
asserted, the last level of Q and Q is latched. This circuit is available in integrated circuit form as the 7475A quad D
latch. Although there are four latches in this IC, there are only two shared enable signals.

Design problems are often simplified by having all transitions in a system occur synchronously (at the same time)
by using a common source of pulses to cause the change. This common pulse is called a clock. The output changes
occur only on either the leading or the trailing edge of the clock pulse. Some ICs have inputs that directly set or
reset the output any time they are asserted. These inputs are labeled asynchronous inputs because no clock pulse
is required. The D-type flip-flop with positive edge-triggering and asynchronous inputs is the 7474. In this
experiment, you will also test this IC.

PRELIMINARY PROCEDURE

1. Read the lab.
2. Number the pins on each circuit using their datasheet.

PROCEDURE

S-R LATCH
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1. Build the S$-R latch shown in Figure 10.1.

+5.0V
&
é 1k
+5.0V
5
Green LED
R1 V¥ Read Q Bar when ON
1k )
4
J U1A
: +5.0V
4 7400 T
Use wire for switch A
4 1k
+5.0V
OB T Red LED
. Reads Q when ON
R2 \
1K U1B o
= 4
0 6 I
5
7400

Figure 10. 1: S-R latch

2. Use a wire to ground either input A or B. The LEDs will be used in this section as logic monitors. Since TTL logic
is much better at sinking current than at sourcing current, the LEDs are arranged to be ON when the output is
LOW (0). Therefore, a HIGH (1) corresponds to an LED being OFF.

3. Complete the truth table in Table 10.1.

Inputs Outputs LEDS
s R Q Q’ Green Red
1 0
1 1
0 1
1 1
0 0

Table 10. 1: Truth table for the S-R latch

D LATCH
4. Modify the basic S -R latch into a D latch circuit shown in Figure 10.2.
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Figure 10. 2: D Latch

-

7400

——u

\‘ 14 W

+
o
o
<

1k

Red LED1
Reads Q when ON

5. Connect the D input to a pulse generator set to 1 Hz, 5Vpp, 2.5V DC off-set. Connect the enable input to a
HIGH (through a 1.0 kQ resistor). Observe the output; then change the enable to a LOW.

6. Complete the truth table in Table 10.2.

Inputs Outputs LEDS
En D Q Q’ Green Red
0 1
0 0
1 1
1 0

Table 10. 2: Truth table for D Latch

99




D Latch — Burglar Alarm

7. Now make a simple burglar alarm shown in Figure 10.3.

Switch:

(Doors, Windows, etc.)

7400

7400 +5.0V

Ready 9,

Enable 330

Red LED

. Alarm Indicator
Y

Standb)j_
o

—
7404

Figure 10. 3: D Latch - Burglar Alarm

—_—

7400
7400

8. The data input is represented by a switch connected to a window or door. The enable input is pulled HIGH
when the system is activated or LOW for standby. To reset the system, put a momentary ground on the Q
output as shown. Open the switch to confirm your alarm is working properly.

9. Complete the truth table in Table 10.3.
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Inputs Outputs LEDS
En D Q Q Red
0 1
0 0
1 1
1 0

Table 10. 3: Truth table for D Latch - Burglar Alarm

THE D FLIP-FLOP

10. Construct the circuit shown in Figure 10.4. Connect the CLK input to a pulse generator set to 1 kHz, 5Vpp, 2.5V
DC off-set.

+5.0V

1k

7474

|
7

Ol
|

—CLK
7404 7404 7404 7404

@ Pulse Generator

CLR

o

1k

+5.0V

Figure 10. 4: D Flip-Flip

11. Connect the clock through the delay circuit. The purpose of the delay is to allow setup time for the D input.
Observe both the delayed clock signal and the Q output signal on a two-channel oscilloscope. View the
delayed clock signal on channel 1 and trigger the scope from channel 1. You should observe a dc level on the
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output (channel 2). Sketch the wave form on Figure 10.5.

CLK

Figure 10. 5: Wave form for part b.

12. Now remove the clock delay by connecting the clock input directly to the pulse generator. The output dc level
should have changed because there is insufficient setup time. Sketch the wave form on Figure 8.6.

CLK

Figure 10. 6: Wave form for part c.

13. Leave the clock delay circuit in place but disconnect the D input. Attach a wire from Q to the D input. Observe
the waveforms on a scope. Normally, for relative timing measurements, you should trigger the scope using the
channel that has the slowest waveform as the trigger channel. Sketch the wave form on Figure 8.7

CLK

Figure 10. 7: Wave form for part d.

14. Determine if PRE and CLR are synchronous or asynchronous inputs.

The PRE and CLR on the 7474 D flip-flop IC are inputs.
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PARITY TEST CIRCUIT

15. Construct the circuit shown in Figure 10.8.

Connect the D input to a pulse generator set to 1 Hz, 5Vpp, 2.5V DC
off-set.
+5.0V
é 330
Green LED
Even Parity Indicator
RN
Y
+5.0V
+5.0V +5.0V
T T
% ) %
1k 330
U15A o 7474
o N S» w |
Red LED
. . — ) o
Wire Switch > D Q ; Odd Parity Indicator
// RN
o 7486 R
_.—I__-—‘ 1 PCLK QP !
=0
@
-
o
[®)

+
a
=}
<

SO —
o"| //‘ VYV

2

(¢}

a)"

Qo

AW —

Figure 10. 8: Parity Test Circuit

16. This is a parity test circuit that takes serial data (bits arriving one at a time) and performs an exclusive-OR on
the previous result. The data are synchronous with the clock; that is, for every clock pulse a new data bit is
tested. Move the data switch to either a HIGH or a LOW prior to the clock pulse and observe the result.

17. Complete the truth table in Table 10.4.
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Inputs Outputs LEDS
Wire Switch D Q Green Red
0 1
0 0
1 1
1 0

Table 10. 4: Truth Table for the Parity Test Circuit
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EVALUATION AND REVIEW QUESTIONS

1. Explain why the circuit in Figure 10.1 can be used to switch debounce a switch.

2. Could NOR gates be used for debouncing a switch? Explain.

3. Show how the burglar alarm of in part C could be constructed with one fourth of a 7475A D latch.

7475A

D Q
EN 6 D]
Figure 10. 9

4. The burglar alarm could be constructed with two cross-coupled NOR gates. Complete the circuit so that it has
the same functions as the alarm in part C (normally closed switches, alarm, and reset).

7402

Figure 10. 10

5. Assume that the burglar alarm in Figure 10.3 does not function correctly. The Enable switch is in the Ready
position but the LED does not come on when one of the switches is open. Suggest at least 3 causes for this
failure. Circle the reason you think is most likely.

6. The serial parity test circuit in Figure 10.8 uses a D flip-flop. Why wouldn’t a D latch work just as well?
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J-K Flip-Flop

OJECTIVES

After completing this experiment, you will be able to
e  Test various configurations for a J-K flip-flop, including the asynchronous and synchronous inputs.
e Observe frequency division characteristics in the toggle mode.
e Measure the propagation delay of a J-K flip-flop.

MATERIALS NEEDED

e  741S76 or 7476 dual J-K flip-flop
e LEDs: one red, one green, one yellow
e  Resistors: seven 3300, four 1.0 kQ

THEORY

JK FLIP-FLOPS

A JK flip-flop is a type of sequential logic circuit that can store one bit of information, also known as a "binary digit"
or "bit". It has two inputs: J (set) and K (reset), and two outputs: Q (the normal output) and Q' (the inverse output).

When both inputs J and K are at logic level 0 (low), the output state of the flip-flop remains unchanged. When J is
set to 1 (high) and K is at 0, the output state of the flip-flop changes to 1, and stays in that state until the inputs are
changed again. Conversely, when K is set to 1 and J is at 0, the output state of the flip-flop changes to 0, and
remains in that state until the inputs are changed again.

When both J and K inputs are set to 1, the output state of the flip-flop toggles. That is, if the output was 0, it
becomes 1, and if the output was 1, it becomes 0.

The toggle function of the JK flip-flop is particularly useful for creating frequency dividers, binary counters, and
other circuits where it is desirable to alternate between two states.

In summary, a JK flip-flop operates by changing its output state based on the combination of inputs J and K, and
can store one bit of information at a time. The truth table for a JK flip-flop is shown in table 9.1.
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Input Output

PRE CLR CLK ) K Q Q
L H X X X 1 0
H L X X X 0 1
H H Ccp 0 0 Memory
H H CP 0 1 0 1
H H CP 1 0 1 0
H H cpP 1 1 Toggle

Table 11. 1: JK Truth Table (CP = Clock Pulse)

PRELIMINARY PROCEDURE

1. Read thelab.
2. Review the J-K flip-flop and number the pins on Figure 11.1, 11.2, 11.3, and 11.4.

PROCEDURE

PART |

1. Construct the circuit shown in Figure 11.1. The LEDS are logic monitors and are ON when their outputs are
LOW.

+5.0V +5.0V

$TTTL oy 220 % 0
i

PRE Bar |:\ . X Red Green
Q
7476 cl )
w
. |n:
J > J & Q
CLK OpCLK
i g ~b
K > K ) QF
O
CLRBar[___> |
-0
Figure 11. 1

2. Set PRE and CLR to HIGH (1). Set CLK to LOW (0), so that it’s not active. Select the “set” mode by setting J =1
and K=0.
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a) Now test the effects of PRE and CLR by putting a logic 0 on each, one at a time. Are preset and clear

inputs synchronous or asynchronous?

3. With the JK flip-flop still in the “set” mode, put PRE HIGH (1) and CLR to LOW (0), then pulse the clock by
flipping the clock switch from 1 to 0 (Note the bubble at the input of the clock). Observe that the CLR input
overrides the J input.

4. Determine what happens if both PRE and CLR are connected to a LOW (0) at the same time. Summarize your
observations in your report.

PART Il

5.

Construct the circuit shown in Figure 11.2. Connect the function generator to the clock input and set it to a 5V

1 Hz square wave with a DC offset of 2.5V. Add an LED clock indicator to the function generator so that you
can observe the clock pulse and the outputs at the same time.

+5.0V
+5.0V
§§§§ § 330 § 330
R's= 330
PRE Bar | !\ Red !\ Green
0y 0y
7476 O ) R
w
N x
J| J o Q
OpcLK
x —
K K |d QP
O
CLR Bar |
) - §330
I Function
—_ Generator @
0 I
_L_
U 4
Clock Indicator
N
-0
Figure 11. 2

6. Test all four combinations of J and K inputs while observing the LEDs. Is data transferred to the output on the
leading or the trailing edge of the clock? Complete Table 11.2.
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Input Output
J K Q Red LED Green LED
1 0
0 1
1 1
0 0

Table 11. 2: Experimental JK flip-flop truth table

7.

Summarize your observations in the report. Include a discussion of the truth table for the J-K flip-flop.
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PART Il

8. Construct the circuit shown in Figure 11.3. Connect the function generator to the clock input and set it to a 5V
5 Hz square wave with a DC offset of 2.5V.

+5.0V
x
+5.0V § 330 § 330
T
% 330 ! Red ! Green
N R
7476 R R
w
o
J o Q
% OpCcLK
330 x
K o QP
Function @
Generator o
! Clock Indicator
< 330
\,
4
1 +5.0V
-0
Figure 11. 3
9. Complete Table 11.3 and summarize your observations in your report.
Current State Next State
J=Q | K=Q Red LED Green LED J=Q | K=Q Red LED Green LED
1 0
0 1

Table 11. 3: Current state, next state

PART IV
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10. An application of the toggle mode is found in certain counters. Cascaded flip-flops can be used to perform
frequency division in a circuit called a ripple counter. Figure 11.4 illustrates a ripple counter using the two flip-
flops in the 74LS76 IC.

11. Construct the circuit shown in Figure 11.4. Connect the function generator to the clock input and set it to a 5V
1 Hz square wave with a DC offset of 2.5V. Notice that when an LED is ON, the Q output is HIGH. The red and
green LEDs indicate that the pulse generator frequency has been changed by the flip-flops.

+5.0V +5.0V
330 330
! Red ! Green
Q 2
1k
’ ’ : ANN—H5.0V
7476 l 7476 l
£ £
J e oF<__lea 3 & or<"_los
. OPCLK A +——OpPCcLK B
330 o _ 24 —
K |5’ QP K |d QP
Function @
Generator 9 Q
J J 1k
Clock Indicator AMN—5.0v
\\: T

.||
o

Figure 11. 4
12. Sketch the QA and QB output on Figure 11.5.
CLK
I I I I I I I
I I I I I I I
QA I I I I I I I
I I I I I I I
I I I I I I I
I I I I I I I
QB | | | | | | |
I I I I I I I
Figure 11. 5

EVALUATION AND REVIEW QUESTIONS

1. Whatis the difference between an asynchronous and a synchronous input?
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Describe how you would set a J-K flip-flop asynchronously.
How would you set it synchronously?

If both J and K inputs are LOW and PRE and CLR are HIGH, what effect does the clock have on the output of a J-
K flip-flop?

Assume a student accidentally reversed the J and K inputs on the circuit in Figure 11.3. What effect would be
observed?

Assume the red LED in Figure 11.3 is on steady and the green LED is off. The yellow LED is blinking. What are
three possible troubles with the circuit?

Assume the green LED in Figure 11.4 is off but the red LED is blinking. A check at the CLK input of the second
flip-flop indicates clock pulses are present. What are possible troubles with the circuit?
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Asynchronous Counter

OJECTIVES

After completing this experiment, you will be able to
e  Build and analyze asynchronous up and down counters.
e Change the modulus of a counter.
e Use an IC counter and truncate its count sequence.

MATERIALS NEEDED

e 7400 quad NAND gates
e 7474 dual D flip-flop

e  7493A binary counter
e 7486 quad XOR gate

e Two LEDs
e Resisters: two 330Q, two 1.0 kQ
THEORY

ASYNCHRONOUS COUNTERS

Digital counters are classified as either synchronous or asynchronous, depending on how they are clocked.
Synchronous counters are made from a series of flip-flops that are clocked together. By contrast, asynchronous
counters are a series of flipflops, each clocked by the previous stage, one after the other. Since all stages of the
counter are not clocked together, a “ripple” effect propagates as various flip-flops are clocked. For this reason,
asynchronous counters are called ripple counters. You can easily make a ripple counter from D or J-K flip-flops by
connecting them in a toggle mode.

The modulus of a counter is the number of different output states the counter may take. The counters you will test
in the first four steps of this experiment can represent the numbers 0, 1, 2, and 3; therefore, they have a modulus
of 4.

Two methods for changing a counter from up to down or vice versa are illustrated in this experiment. The first
method involves moving the logical “true” output of the counter to the other side (as illustrated in Figures 10.2
and 10.3). The second method changes the way the counter is triggered.

If we tabulate a binary count sequence, we note that the LSB (least significant bit) changes at the fastest rate and
the rate of change is divided by 2 as we look at succeeding columns. A typical 3-Stage counter might have output
waveforms as shown in Figure 10.1. For this counter, we can assign each output with a “weight” equal to the
column value that would be assigned to binary numbers. Output QA has a weight of 1, output QB has a weight of
2, and output QC has a weight of 4. For the counter shown, the count sequence is for an up counter.
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Counter

0||1 0]1!0,1!0 1o]7}
O 7
1
otofTT1lo0fT 100!
Clock 0 J11110,0: 1'
— Qutputs T T -
[
ololoiofTiTiirTlol0! I
QC 1| I_{ I —— . |I E
I
| ] |
1 [ |
[
MSBY ¥ V¥ LSB
Qc Oz Qs
0 0 0
0 0 1
01 0
0 1 1
1 0 0
1 0 1
I 1 0
11 1
00 0
0 0 I}Repeats
Figure 12. 1

For most applications requiring a counter, MSI counters are available. The 7493A is an example of an asynchronous
counter containing four J-K flip-flops, with the J and K inputs internally wired HIGH, putting them in the toggle
mode. Three of the flip-flops are connected together as a 3-bit counter. The fourth flip-flop is separate, including
its own clock input. To form a 4-bit counter, connect the QA output of a single J-K flip-flop to the clock B input of
the 3-bit counter. A common reset line goes to all flip-flops. This reset line is controlled by an internal 2-input
NAND gate. You can select any count sequence up to 16 by choosing the internal counter, detecting the desired
count, and using it to reset the counter. In the For Further Investigation section, you will be introduced to an idea
for changing the up/down count sequence using a control signal.

PRELIMINARY PROCEDURE

1. Read the lab.
2. Review asynchronous counters and number the pins on Figure 10.2, 10.3, 10.4, 10.5, 10.6, 10.7, 10.8, and

10.9.
PROCEDURE

Note: The LED indicators in this experiment are connected through NAND gates wired as inverters to form the
display portion of the circuit. Although not strictly necessary, this method enables you to more easily visualize the
ideas presented in the experiment.

PART I
1. Construct the 2-bit asynchronous counter shown in Figure 12.2. Clock flip-flop A using a 5V 1 Hz square wave
(2.5V DC offset) from the function generator to the clock input and watch the sequence on the LEDs.
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Figure 12. 2

2. Speed up the generator to 1 kHz and view the A and B output waveforms on a dual-channel oscilloscope. If
the clock frequency is not stated in other parts, use 1 kHz to view signals on the oscilloscope. Trigger the
oscilloscope from channel 1 while viewing the B signal on channel 1 and the A signal or the clock on channel 2.
Sketch the output timing diagram in Figure 12.3.

CLK

Figure 12. 3

3. By observation of your waveforms, determine whether this is an up counter or a down counter, and record
your answer.

PART Il

4. Now we will change the way we take the “true” output from the counter and see what happens. If logic
“truth” is taken from the other side of each flip-flop, then we have the circuit shown in Figure 12.4.
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Figure 12. 4

5. Maodify your circuit and view the output waveform from each stage. Sketch the timing diagram on Figure 12.5
of the report.

CLK

Figure 12. 5

6. By observation of your waveforms, determine whether this is an up counter or a down counter, and record
your answer.

PART IlI
7. Next, we will change the manner in which flip-flop B is clocked. Change the circuit to that of Figure 12.6.
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8. The “true” output of the counter remains on the Q side of the flip-flops. View the outputs as before and
sketch the waveforms on Figure 12.7.
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Figure 12. 6
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Figure 12. 7

9. By observation of your waveforms, determine whether this is an up counter or a down counter, and record

your answer.

PART IV

10. Now change the logic “true” side of the counter, but do not change the clock, as illustrated in Figure 12.8.
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Figure 12. 8

11. Again, sketch the outputs of each flip-flop on Figure 12.9.

CLK

Figure 12.9

12. By observation of your waveforms, determine whether this is an up counter or a down counter, and record
your answer.

PART V

13. You can change the modulus of the counter by taking advantage of the asynchronous clear (CLR) and
asynchronous preset (PRE) inputs of the 7474. Look at the circuit of Figure 12.10, a modification of the circuit
in Figure 10.5. Predict the behavior of this circuit, and then build the circuit.
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14. Set the clock frequency at 500 kHz and look for the very short spike that causes the count sequence to be
truncated. Sketch the output waveforms of each flip-flop on 12.11 and determine the count sequence.

CLK

Figure 12. 11

15. By observation of your waveforms, determine whether this is an up counter or a down counter, and record
your answer.

PART VI

16. You can configure the 7493A 4-bit binary counter to count from 0 to 15 by connecting the output of the single
flip-flop (QA) to the clock B input. Connect the function generator to the clock A input. From the data sheet,
determine the necessary connections for the reset inputs.
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Figure 12. 12

17. Set the clock for 400 kHz. Trigger a two-channel oscilloscope from the lowest-frequency symmetrical

waveform (QD), and observe, in turn, each output on the second channel. Sketch the timing diagram on Figure

12.13.

QA
QB
QC
QD

Figure 12. 13

PART VII

18. Figure 12.14 shows a 7493A counter configured with a truncated count sequence. Modify your previous circuit

(Figure 12.13) and observe the output waveforms on an oscilloscope. Again, trigger the oscilloscope on the

lowest-frequency symmetrical waveform, and observe each output on the second channel.
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Figure 12. 14

19. Sketch the timing diagram on Figure 12.15.

QA
QB
QC
QD

Figure 12. 15

20. By observation of your waveforms, determine whether this is an up counter or a down counter, and record

your answer.
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EVALUATION AND REVIEW QUESTIONS

1. Figure 12.16 shows a digital oscilloscope display for the circuit in Figure 10.4, but with a different clock
frequency. The upper signal is B on CH1. The lower signal is A on CH2.

a) What is the clock frequency?

b) Why is it best to trigger the scope on CH1?
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! ! 1 mm
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O S N 1 I U SN N SO S Py
Il | E l i Lo CH2
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I ] i 1 | [ 400V
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N HERE CH1

PN SR L S . 1o [ None
[ | 1 1 [ 1 i I I .
o : : j : | | : CH1

' I A B A B e e S .
o P
s ol o byw s o Py e e T aaly ' A |
CHI 2.00vVv CHZ 2.00V M 50.0us CH1 208V
Figure 12. 16

2. Explain how the count sequence of a ripple counter can be truncated.

a) Why does the procedure produce a glitch?
3. Suppose that the counter in Figure 12.4 has both LEDs on all the time. The clock is checked and found to be
4. present. What possible faults would cause this condition?

5.  Why shouldn’t you trigger your oscilloscope from the clock when determining the time relationship of the
outputs of a counter?

6. Draw the circuit for a 7493A configured as a modulus-9 counter.

a) Sketch the waveforms you would see from the circuit.
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QA
QB
QC
QD

Figure 12. 17

Assume the 7493A in Figure 12.12 were replaced with a 7492A and wired the same way. Referring to the

count sequence shown on the data sheet, determine the modulus and count sequence of the circuit.

7.
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Analysis of Synchronous Counters with Decoding

OJECTIVES

After completing this experiment, you will be able to:
e Analyze the count sequence of synchronous counters using a tabulation method.
e Construct and analyze a synchronous counter with decoding. Draw the state diagram.
e Use an oscilloscope to measure the time relationship between the flip-flops and the decoded output.
e  Explain the concept of patrial decoding.

MATERIALS NEEDED

e Two 7476 dual J-K flip-flops.
e 7400 quad NAND gates.
e  Two SPST N.O. pushbutton (N.O. means Normally Open).

e Four LEDs.
e Resistors: four 330Q, two 1.0kQ.
THEORY

SYNCHRONOUS COUNTERS

Synchronous counters have all clock lines tied to a common clock, causing all flip-flops to change at the same time.
For this reason, the time from the clock pulse until the next count transition is much faster than in a ripple counter.
This greater speed reduces the problem of glitches (short, unwanted signals due to non-synchronous transitions) in
the decoded outputs. However, glitches are not always eliminated because stages with slightly different
propagation delays can still have short intermediate states. One way to eliminate glitches is to choose a Gray code
count sequence (only one flip-flop transition per clock pulse).

Decoding is the “detecting” of a specific number. A counter with full decoding has a separate output for each state
in its sequence. The decoded output can be used to implement some logic that performs a task. The decoded
outputs are also useful for developing counters with irregular count sequences. This experiment will also introduce
you to partial decoding, a technique that allows you to decode the output with less than all the bits.

Several MSI counters are available with features on one chip, such as synchronous and asynchronous preset or
clear, up/down counting, parallel loading, display drivers, and so on. If it is possible to use an MSI counter for an
application, this choice is generally the most economical. If it is not possible, then you must design the counter to
meet the requirement. In this experiment you will analyze already designed synchronous counters step by step. In
the next experiment, you will design a counter to meet a specific requirement.

HOW TO ANALYSIS PRE-DESIGNED SYNCHRONOUS COUNTERS

The method for analyzing a synchronous counter is a systematic tabulation technique. This method is illustrated
for the counter shown in Figure 13.1. Begin by setting up Table 13.1. The table lists the outputs and inputs for each
flip-flop in the counter.
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1. Write the equations for the J and K inputs of each counter using the schematic shown in Figure 11.1. The

equations are shown in Table 13.1.

2. Assume an initial state for the counter. In this example, let’s arbitrarily choose 0000,.

Complete the first row by determining each J and K input. The equations (Step 1) and the inputs 0000, are used to
compute the binary value of J and K.

Outputs Inputs
b= Kp = Je= Ke= Jg = Kg = Ja= K, =
Op @c Qs Qa Qs ' Qc Ca Q4 Qg Op Q4 9o Qc Qs - QOc Qs
P20 o o0 o 0 0 0 0 1o 0 I 0
0 0 0 1 1 t \ Y
Step 4 — —sieh 3 Nsgp!1 —
'W-KAJV'WMJW“MNH
Table 13.1
3.

Use the J-K truth table to determine the next state of each flip-flop. In this example, Jp = Kp = 0 means Qp will
not change; also notice that Qc and Qg will not change. However, Ja = 1, Ky = 0 means Qu = 1 after the next
clock pulse. Write the next state under the present state that was originally assumed.
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Outputs Inputs
Jo= Kp = Je= Ko = Jg = Kp = A = Ky=
Op Qc Qs Q4 Qs " Qc Oa Qa Ca Oo Qa" O Qc Qs - Qc Qs
0 0 0 0 0 0 0 0 0 0 1 0
Ls0 0 0 | 0 1 0 0 1 0 1 0
8 0 0 I 1 0 1 0 0 1 0 0 1
g 0 0 1t 0 0 0 1 0 0 0 0 1
g 0 1 1 0 0 0 1 0 0 1 0 1
g 0 1 0 0 1 0 0 0 0 ! 0 0
= 1 1 0 0 1 0 0 1 0 l 0 0
1 ¢ 0 o 0 0 0 1 0 0 1 0
1 0 0 l 0 1 0 1 0 0 1 0
0 0 0 1 Al this step, a repeated pattern is noted.
1 1 0 | 11 o [ 1 o 1l o 0
0o 0 0 1 Returns to main sequence
g 0 1 0 1 1 I 0 0 1 1 0 0
g 11 11 0 1 0 1 0 1 0 !
g 0 0 0 o Returns to previously tested state (0000)
2 0 1 1 1 o [ 1+ fo | o [ 1 o 1
<
5 0 1 0 1 Returns to previously tested state (0101)
-5' 1 0 1 0 0 0 1 1 0 1
§ 1 I 1 0 0 0 1 1 1 1
< 1 0 0 o Returns to main sequence
10 1 1 0 1 Lo [ 1 o o [ o 1
0 0 1 0 Returns to main sequence
Table 13. 2

4. Continue until all possible inputs are accounted for. This is demonstrated in Table 13.2. The sequence can now
be shown on a state diagram, as in Figure 13.2.

Main
sequence

Figure 13. 2

The analysis continues along these lines until all possible (2V) states have been taken into account, including states
that are not in the main count sequence. The completed table is shown as Table 13.2. Using the information from
the table, the complete state diagram can then be drawn as illustrated in Figure 13.2. This completely describes
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the operation of the counter. This particular counter has an interesting and somewhat unusual application. It is
used to develop the proper sequence of signals necessary to half-step a stepper motor.

PRELIMINARY PROCEDURE

1. Review synchronous counters and read the lab.
2.  Number the pins on Figure 13.3, 13.4, and 13.5.

3. Complete Table 13.2 and draw the state diagram. Examine the counter shown in Figure 13.3. Since there are
two flip-flops, there are four possible output states. Analyze the sequence by completing Table 13.2 using the
method illustrated in the Theory section. From the table, draw the predicted state diagram.

Output Inputs
QB QA JB = KB = JA = KA —
Table 13. 3

4. Analyze the counter shown in Figure 13.5 by completing Table 13.3. Account for all possible states, including
unused states. If you correctly account for the unused states, you will see that all unused states return to state

2. Draw the state diagram.

Outputs

Inputs

Qc Qs

Qa

Jc=

Kc

Jg=

Ks=

Ia=

Ka=

Table 13. 4
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PROCEDURE

1. Build the synchronous counter circuit shown in Figure 13.3.
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Figure 13. 3

2. Build the NAND gates circuits shown in Figure 13.4, which serve as state decoders with an active-LOW output
for each state. To avoid confusion, the lines from the counter to the decoders are not shown on the
schematic. Save the decoder circuits as they will be used with the next counter circuit in this lab.

3. Set the function generator to 5V, 2.5Vpc.oft-set, and 1Hz for the clock signal. Observe the order in which the
decoders LEDs are illuminated. Are they showing the correct sequence? If not, debug your circuit until the
decoder circuit shows the correct sequence.

4. Use an oscilloscope to measure Qg and Qa. Set the oscilloscope to trigger on channel 1 with the Qg signal. Set

channel to Qa and fit both signals on to the screen. Observe that your waveforms match the state sequence.
Photograph or save the oscilloscope screen on a USB drive for your report.
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Figure 13. 4

Assume that a failure has occurred in the circuit. The wire from the Qg output to Ka has become open. What
effect does this open have on the output? Look at the signals on your oscilloscope and determine the new
state diagram. Add the state diagram to your report.

Modify the circuit by adding another flip-flop and changing the inputs to Ja, Ka, and Jg, as shown in Figure 13.5.

Leave the 7400 decoder circuit but remove the set and clear switches/buttons. The decoder circuit will form
an example of partial decoding—a technique frequently employed in computers.
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EVALUATION AND REVIEW QUESTIONS

7476

PRE [0—

PRE [0—F

@
il

7476 7476 (0]
| | ¢
@
J J J o
Q- Q- Q
JK A JK B JK C
— 1Y PCLK —OpCLK
Q P— Q pP— Q
ad © o
K N N
] ] ]
§ 1k
Function Generator 1
. +5.0V
Figure 13.5

Set the function generator (CLK) to 1 Hz and observe the LEDs connected to the state decoders. Notice that

state 4 is not in the main sequence but state 0 is in the main sequence of the counter. This means that every
time the state 0 LED turns ON, the counter is actually in state 0. This is an example of partial decoding; the
MSB was not connected to the decoder, yet there is no ambiguity for state 0 because state 4 is not possible.

Likewise, there is no ambiguity for state 0 or state 7, but partial decoding is not adequate to uniquely define
states 2 and 6.

1.

The counter used for half-stepping a stepper motor in the example of Figure 13.1 has a state diagram

sequence that is shown in Figure 13.2. Beginning with state 1, sketch the Qp, Qc, Qg, and Qa outputs. (Hint: An

easy way to start is to write the binary number vertically where the waveforms begin. This procedure is

started as an example.)
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Figure 13. 6

2. Determine the sequence of the counter shown in Figure 13.7 and draw the state diagram.
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1.0kQ
+50V
Figure 13. 7

3. How could you incorporate full decoding into the counter circuit shown in Figure 13.5?

4. Explain the changes you would make to the circuit in Figure 13.5 in order to add a pushbutton that resets the
counter into state 2.

5. Assume a problem exists with the counter shown in Figure 13.3. The counter is “locked-up” in state 3. What
are two faults that can account for this problem?

6. Assume the synchronous counter in Figure 13.1 is “locked-up” in state 9. A quick check of power, ground, and
clock indicate they are all 0.K. Which flip-flop is the likely cause of the problem? Why?
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Design of Synchronous Counters

OJECTIVES

After completing this experiment, you will be able to:
e Design a synchronous counter with up to 16 states in any selected order.
e Construct and test the counter. Determine the state diagram of the counter.

MATERIALS NEEDED

e Two 7476 dual J-K flipflops
e 7408 quad AND gate or other SSI IC determined by the student’s design.

THEORY

DESIGNING SYNCHRONOUS COUNTERS

The design of a synchronous counter begins with a description of the state diagram that specifies the required
sequence. All states in the main sequence should be shown; states that are not in the main sequence should be
shown only if the design requires these unused states to return to the main sequence in a specified way. If the
sequence can be obtained from an already existing IC, this is almost always more economical and simpler than
designing a special sequence.

HOW TO DESIGN SYNCHRONOUS COUNTERS

From the state diagram, a next-state table is constructed. This procedure is illustrated with the example in Figure
20-1 for a simple counter and again in Figure 20-3 for a more complicated design. Notice in Figure 20-1 that the
next state table is just another way of showing the information contained in the state diagram. The advantage of
the table is that the changes made by each flip-flop going from one state to the next state are clearly seen. The
third step is to observe the transitions (changes) in each state. The required logic to force these changes will be
mapped onto a Karnaugh map. In this case, the Karnaugh map takes on a different meaning than it did in
combinational logic but it is read the same way. Each square on the map represents a state of the counter. In
effect, the counter sequence is just moving from square to square on the Karnaugh map at each clock pulse. To
find the logic that will force the necessary change in the flip-flop outputs, look at the transition table for the J-K
flip-flop, shown as Table 20-1. Notice that all possible output transitions are listed first; then the inputs that cause
these changes are given. The transition table contains a number of X’s (don’t cares) because of the versatility of
the J-K flip-flop, as explained in the text. The data from the transition table are entered onto the Karnaugh maps as
illustrated.

Assume you need to design a counter that counts 0-1-3-2 and stays in state 2 until a reset button is pressed. Two
flip-flops are required. Let Qz = MSB and Qu = LSB. Use a J-K flip-flop.

1. Draw a state diagram.

Figure 14. 1

2. Draw next-state table.
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Present Next
state state
Qp Q4|9 @
0 0 0 1
0 1 1 1
1 1 1 0
1 0 1 0
Table 14. 1
Output
Transitions Inputs
On On+1 Iy Ky
0 - 0 0 X
0 E 1 1 X
1 E 0 X
1 E 1 X 0
Table 14. 2

3. Determine inputs required for each flip-flop.
a) Read present state 00 on next-state table.
b) Note the Qg does not change 0 = 0 (present to next state) and Qa changes from 0 1.
c) Read the required inputs to cause these results from transition Table 14.2.

d) Map each input from transition table onto Karnaugh map.

o
t
N

o

/s Ky Ja Ky
e 00 M3B el P
Figure 14. 2
e) Complete maps
Q4 Q4 04 ()

OND0 1 oN'o 1 floNlo 1 oX'o i
of o | olx[x| ol ofx[ol
i[x X 1fofo I 1[o]x @& T!

= — — CeETR
Jg Ky A K,
Figure 14. 3

f)  Read minimum logic from each map.
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Jo=Qa, Ke=0, Ja=Qp, Ka=Qs
4. Draw circuit and check.

Step 4: Draw circuit and check. +50V
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? 1.0KO ke pushbutton
+50V
Figure 14. 4

When the maps are completed, the logic can be read from the map. This logic is then used to set up the circuit as
shown in Step 4 of Figure 20-1. It is a good idea to check the design by verifying that the count sequence is correct
and that there are no lock-up states. (A lock-up state is one that does not return to the main sequence of the
counter.) The design check can be done by completing a table such as Table 13.2 in the last experiment.

The design procedure just described can be extended to more complicated designs. In Experiment 13 a counter
was shown (Figure 13.1) that generates the required waveforms for half-stepping a stepper motor.

PRELIMINARY PROCEDURE

1. Read thelab.

2. A Gray code synchronous counter is often used in state machine design. This problem requires a six-state Gray
code counter. The usual Gray code sequence is not used because the sixth state would not be “Gray” when
the counter returns to zero. Instead, the sequence shown in Figure 14.5 is required. There are two unused
states: state 5 and state 7. For the initial design, these states are not shown. Complete the next-state table in
the report for the main sequence shown here.

Main sequence

Figure 14. 5

Present and Next State J-K Flop-Flop Inputs
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3. Using the transition table for the J-K flipflop, complete the Karnaugh maps shown in the report. The J-K
transition table (Table 14.2) is repeated in the report for convenience.

4. Read the required logic expressions from each map that you completed in preliminary procedure. Check that

the unused states return to the main sequence. If they do not, modify the design to assure that they do
return.

PROCEDURE

1. Construct and test your circuit. You can check the state sequence with an oscilloscope or a logic analyzer.
Summarize the results of your test in your report.

EVALUATION AND REVIEW QUESTIONS

1. Complete the design of the sequential counter in Figure 14.3 by constructing Karnaugh maps for the Band A
flip-flops. Read the maps. As a check, you can compare your result with the circuit drawn in Figure 14-1.

2. Describe the logic necessary to add a seven-segment display to the circuit you designed in this experiment to
enable the display to show the state of the counter.

3. Assume you wanted to make the sequential circuit you designed in this experiment start in state 6 if a reset
pushbutton is pressed. Describe how you would modify the circuit to incorporate this feature.

4. Assume you wanted to change the circuit from this experiment to be able to reverse the sequence. How
would you go about this?

5. Assume you wanted to trigger a one-shot (74121) whenever the circuit you designed went into state 2 or state
4. Explain how you could do this.

6. Draw the transition table for a D flip-flop. Start by showing all possible output transitions (as in the J-K case)
and consider what input must be placed on D in order to force the transition.

a) Why is the J-K flip-flop more versatile for designing synchronous counters with irregular sequences?
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